summaryrefslogtreecommitdiff
path: root/INSTALL.rst
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2016-03-06 04:04:07 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2016-03-06 04:04:07 +0100
commit28e178a796cc5da990b23c09d69e37ed00f15a68 (patch)
treef9ec997d2af4a320064eb580ec1d975cee9b7390 /INSTALL.rst
parent35bc2fe32093b19ae91d9e765d222da2b638855c (diff)
downloadpsutil-28e178a796cc5da990b23c09d69e37ed00f15a68.tar.gz
update INSTALL / DEVGUIDE
Diffstat (limited to 'INSTALL.rst')
-rw-r--r--INSTALL.rst70
1 files changed, 30 insertions, 40 deletions
diff --git a/INSTALL.rst b/INSTALL.rst
index 49414a2e..d2cb022d 100644
--- a/INSTALL.rst
+++ b/INSTALL.rst
@@ -1,22 +1,20 @@
-.. note::
- pip is the easiest way to install psutil.
- It is shipped by default with Python 2.7.9+ and 3.4+. If you're using
- an older Python version
- `install pip <https://pip.pypa.io/en/latest/installing/>`__ first.
+*Note: pip is the easiest way to install psutil.
+It is shipped by default with Python 2.7.9+ and 3.4+. If you're using an
+older Python version* `install pip <https://pip.pypa.io/en/latest/installing/>`__
+*first.*
-=====
Linux
=====
-Ubuntu::
+Ubuntu / Debian::
- sudo apt-get install gcc python-dev
- pip install psutil
+ $ sudo apt-get install gcc python-dev
+ $ pip install psutil
RedHat::
- sudo yum install gcc python-devel
- pip install psutil
+ $ sudo yum install gcc python-devel
+ $ pip install psutil
OSX
===
@@ -26,7 +24,7 @@ first, then:
::
- pip install psutil
+ $ pip install psutil
Windows
=======
@@ -35,7 +33,7 @@ The easiest way to install psutil on Windows is to just use the pre-compiled
exe/wheel installers on
`PYPI <https://pypi.python.org/pypi/psutil/#downloads>`__ via pip::
- C:\Python27\python.exe -m pip install psutil
+ $ C:\Python27\python.exe -m pip install psutil
If you want to compile psutil from sources you'll need **Visual Studio**
(Mingw32 is no longer supported):
@@ -50,51 +48,43 @@ Once installed run vcvars64.bat, then you can finally compile (see
`here <http://stackoverflow.com/questions/11072521/>`__).
To compile / install psutil from sources on Windows run::
- make.bat build
- make.bat install
+ $ make.bat build
+ $ make.bat install
FreeBSD
=======
-XXX
+::
+
+ $ pkg install python gcc
+ $ python -m pip install psutil
OpenBSD
=======
-Note - tested on OpenBSD 5.8::
+::
- PKG_PATH=http://mirrors.nycbug.org/pub/OpenBSD/5.8/packages/i386/
- export PKG_PATH
- pkg_add -v python
- python -m pip install psutil
+ $ export PKG_PATH=http://ftp.usa.openbsd.org/pub/OpenBSD/`uname -r`/packages/`arch -s`
+ $ pkg_add -v python gcc
+ $ python -m pip install psutil
NetBSD
======
-Note - tested on NetBSD 7.0::
+::
- PKG_PATH="http://ftp.netbsd.org/pub/pkgsrc/packages/NetBSD/i386/7.0/All"
- export PKG_PATH
- pkg_add -v pkgin
- pkgin install python
- python -m pip install psutil
+ $ export PKG_PATH="ftp.netbsd.org/pub/pkgsrc/packages/NetBSD/`uname -m`/`uname -r`/All"
+ $ pkg_add -v pkgin
+ $ pkgin install python gcc
+ $ python -m pip install psutil
Solaris
=======
XXX
-========
-Makefile
-========
-
-A makefile is available for both UNIX and Windows (make.bat). It provides
-some automations for the tasks described above and might be preferred over
-using setup.py. It is useful only if you want to develop for psutil.
-Some useful commands::
+Dev Guide
+=========
- $ make install # just install (in --user mode)
- $ make uninstall # uninstall (needs pip)
- $ make setup-dev-env # install all dev deps for running tests, building doc, etc
- $ make test # run tests
- $ make clean # remove installation files
+If you plan on hacking on psutil you may want to take a look at the
+`dev guide <https://github.com/giampaolo/psutil/blob/master/DEVGUIDE.rst>`__.