summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2022-06-24 15:05:14 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2022-06-24 15:05:14 +0200
commit84e9ffa7b55811dc7c22c04ccb7002bd891486d5 (patch)
tree7f29ceccc16ac785d9b83cf2d59fed66e8c2b706 /Makefile
parent5b6fb8987e657b319fb74d90bc4276173246682f (diff)
downloadpsutil-84e9ffa7b55811dc7c22c04ccb7002bd891486d5.tar.gz
make fix-flake8: parallelize autoflake8 execution
...by pip-installing a PR I provided for autoflake8 packages which adds --jobs option to the tool, see https://github.com/PyCQA/autoflake/pull/107 Signed-off-by: Giampaolo Rodola <g.rodola@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 4910c13e..8954e72f 100644
--- a/Makefile
+++ b/Makefile
@@ -9,7 +9,7 @@ TSCRIPT = psutil/tests/runner.py
# Internal.
DEPS = \
- autoflake \
+ git+https://github.com/PyCQA/autoflake.git@refs/pull/107/head \
autopep8 \
check-manifest \
concurrencytest \
@@ -213,7 +213,7 @@ lint-all: ## Run all linters
fix-flake8: ## Run autopep8, fix some Python flake8 / pep8 issues.
@git ls-files '*.py' | xargs $(PYTHON) -m autopep8 --in-place --jobs 0 --global-config=.flake8
- @git ls-files '*.py' | xargs $(PYTHON) -m autoflake --in-place --remove-all-unused-imports --remove-unused-variables
+ @git ls-files '*.py' | xargs $(PYTHON) -m autoflake --in-place --jobs 0 --remove-all-unused-imports --remove-unused-variables --remove-duplicate-keys
fix-imports: ## Fix imports with isort.
@git ls-files '*.py' | xargs $(PYTHON) -m isort --settings=.isort.cfg