summaryrefslogtreecommitdiff
path: root/make.bat
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2016-02-04 09:31:16 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2016-02-04 09:31:16 +0100
commitbb13d64caf3c93659fe555d5ca8fbba23ac9e966 (patch)
tree9f516d19d654a2bdf7e0949d9e678fcf4a1dfaf2 /make.bat
parenta1ca4ade2f72a30bc94820b99097957f60a09773 (diff)
parent9284b544be631b8595a027cebfcf2cfdd2465ef2 (diff)
downloadpsutil-bb13d64caf3c93659fe555d5ca8fbba23ac9e966.tar.gz
Merge pull request #660 from seeq12/make-bat-visual-studio-location
Improve make.bat's resiliency to Visual Studio install locations
Diffstat (limited to 'make.bat')
-rw-r--r--make.bat8
1 files changed, 5 insertions, 3 deletions
diff --git a/make.bat b/make.bat
index 8f0cb1b7..35b9fd56 100644
--- a/make.bat
+++ b/make.bat
@@ -26,6 +26,8 @@ if "%TSCRIPT%" == "" (
set TSCRIPT=test\test_psutil.py
)
+set VSINSTALLDIR=%VS90COMNTOOLS%..\..
+
set PYTHON26=C:\Python26\python.exe
set PYTHON27=C:\Python27\python.exe
set PYTHON33=C:\Python33\python.exe
@@ -77,7 +79,7 @@ if "%1" == "clean" (
if "%1" == "build" (
:build
- "C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\vcvars64.bat"
+ "%VSINSTALLDIR%\VC\bin\vcvars64.bat"
%PYTHON% setup.py build
if %errorlevel% neq 0 goto :error
rem copies *.pyd files in ./psutil directory in order to allow
@@ -131,7 +133,7 @@ if "%1" == "test-memleaks" (
if "%1" == "build-all" (
:build-all
- "C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\vcvars64.bat"
+ "%VSINSTALLDIR%\VC\bin\vcvars64.bat"
for %%P in (%ALL_PYTHONS%) do (
@echo ------------------------------------------------
@echo building exe for %%P
@@ -148,7 +150,7 @@ if "%1" == "build-all" (
if "%1" == "upload-all" (
:upload-exes
- "C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\vcvars64.bat"
+ "%VSINSTALLDIR%\VC\bin\vcvars64.bat"
for %%P in (%ALL_PYTHONS%) do (
@echo ------------------------------------------------
@echo uploading exe for %%P