summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorelie <elie>2013-09-21 10:07:56 +0000
committerelie <elie>2013-09-21 10:07:56 +0000
commit657943705a150701905b1aa75498a4910c2e5d13 (patch)
tree76adf043beb0086b8b01a8239fcaa74e27a0e06d /setup.py
parenteaa403616e3a48e590c6feb3f61877e6d87e4653 (diff)
downloadpyasn1-git-657943705a150701905b1aa75498a4910c2e5d13.tar.gz
python 2.4+ installation requirement added
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 2817cbc..3382b2b 100644
--- a/setup.py
+++ b/setup.py
@@ -38,6 +38,10 @@ def howto_install_setuptools():
Then you could make eggs from this package.
""")
+if sys.version_info[:2] < (2, 4):
+ print("ERROR: this package requires Python 2.4 or later!")
+ sys.exit(1)
+
try:
from setuptools import setup, Command
params = {