summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorelie <elie>2010-07-08 21:12:34 +0000
committerelie <elie>2010-07-08 21:12:34 +0000
commit5a70aec9057b2780941be2d0618a88ea299d113f (patch)
treef2e63f4f04828e076b3cfb33165e09b68638388c /setup.py
parent251a2bdfab742810073161e2deeb44c5f867f2f5 (diff)
downloadpyasn1-5a70aec9057b2780941be2d0618a88ea299d113f.tar.gz
switched to MANIFEST template
updated setup() keywords fix to egg detection
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py19
1 files changed, 10 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index cc86ea5..267ff6e 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,6 @@
#!/usr/bin/env python
import sys
+import string
def howto_install_setuptools():
print """Error: You need setuptools Python package!
@@ -13,22 +14,22 @@ try:
from setuptools import setup
except ImportError:
for arg in sys.argv:
- if "egg" in arg:
+ if string.find(arg, 'egg') == -1:
howto_install_setuptools()
sys.exit(1)
from distutils.core import setup
-setup(name="pyasn1",
- version="0.0.11a",
- description="ASN.1 library for Python",
- author="Ilya Etingof",
- author_email="ilya@glas.net ",
- url="http://sourceforge.net/projects/pyasn1/",
+setup(name = 'pyasn1',
+ version = '0.0.11a',
+ description = 'ASN.1 types and codecs',
+ author = 'Ilya Etingof',
+ author_email = 'ilya@glas.net',
+ url = 'http://sourceforge.net/projects/pyasn1/',
+ license = 'BSD',
packages = [ 'pyasn1',
'pyasn1.type',
'pyasn1.codec',
'pyasn1.codec.ber',
'pyasn1.codec.cer',
- 'pyasn1.codec.der' ],
- license="BSD"
+ 'pyasn1.codec.der' ]
)