summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorelie <elie>2006-05-28 20:26:18 +0000
committerelie <elie>2006-05-28 20:26:18 +0000
commitd94b0495341ee50de40046dae2d3e70158def1b7 (patch)
tree05acc275f4fcf0d804564545cb03d7cd8640e2cc /setup.py
parent4f3a2c5224b3845a1e26bd86e34dcd7774815ba4 (diff)
downloadpyasn1-d94b0495341ee50de40046dae2d3e70158def1b7.tar.gz
playing with setuptools
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py19
1 files changed, 18 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 36a9800..19eb815 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,22 @@
#!/usr/bin/env python
-from distutils.core import setup
+import sys
+
+def howto_install_setuptools():
+ print """Error: You need setuptools Python package!
+
+It's very easy to install it, just type (as root on Linux):
+ wget http://peak.telecommunity.com/dist/ez_setup.py
+ python ez_setup.py
+"""
+
+try:
+ from setuptools import setup
+except ImportError:
+ for arg in sys.argv:
+ if "egg" in arg:
+ howto_install_setuptools()
+ sys.exit(1)
+ from distutils.core import setup
setup(name="pyasn1",
version="0.0.5a",