summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreli.bendersky <devnull@localhost>2011-03-06 07:56:55 +0200
committereli.bendersky <devnull@localhost>2011-03-06 07:56:55 +0200
commitb56e8f8be981c91be3eef1b80e6b2dfccfae57e2 (patch)
tree484c3c3006b0ee98c997e14905c4332d4c904d9c
parentb36f5bb09f44065343bdbbca06d370ecdeafaba8 (diff)
downloadpycparser-b56e8f8be981c91be3eef1b80e6b2dfccfae57e2.tar.gz
preparing for release 2.03release_v2.03
-rw-r--r--README.html26
-rw-r--r--README.txt22
-rw-r--r--TODO.txt14
-rw-r--r--pycparser/__init__.py4
-rw-r--r--setup.py2
5 files changed, 41 insertions, 27 deletions
diff --git a/README.html b/README.html
index 93969da..4830f4d 100644
--- a/README.html
+++ b/README.html
@@ -4,7 +4,7 @@
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="generator" content="Docutils 0.6: http://docutils.sourceforge.net/" />
-<title>pycparser v2.02</title>
+<title>pycparser v2.03</title>
<meta name="author" content="Eli Bendersky" />
<style type="text/css">
@@ -305,8 +305,8 @@ ul.auto-toc {
</style>
</head>
<body>
-<div class="document" id="pycparser-v2-02">
-<h1 class="title">pycparser v2.02</h1>
+<div class="document" id="pycparser-v2-03">
+<h1 class="title">pycparser v2.03</h1>
<table class="docinfo" frame="void" rules="none">
<col class="docinfo-name" />
<col class="docinfo-content" />
@@ -387,8 +387,8 @@ ul.auto-toc {
<div class="section" id="prerequisites">
<h2>2.1&nbsp;&nbsp;&nbsp;Prerequisites</h2>
<ul class="simple">
-<li><tt class="docutils literal"><span class="pre">pycparser</span></tt> was tested on Python 2.5, 2.6 and 3.1, on both Linux and Windows</li>
-<li><tt class="docutils literal"><span class="pre">pycparser</span></tt> uses the PLY module for the actual lexer and parser construction. Install PLY version 3.3 (earlier versions work at least since 2.5) from <a class="reference external" href="http://www.dabeaz.com/ply/">its website</a>.</li>
+<li><tt class="docutils literal"><span class="pre">pycparser</span></tt> was tested on Python 2.6 and 3.2, on both Linux and Windows. It should work on any later version (in both the 2.x and 3.x lines) as well.</li>
+<li><tt class="docutils literal"><span class="pre">pycparser</span></tt> uses the PLY module for the actual lexer and parser construction. Install PLY from <a class="reference external" href="http://www.dabeaz.com/ply/">its website</a>.</li>
</ul>
</div>
<div class="section" id="installation-process">
@@ -413,7 +413,7 @@ ul.auto-toc {
</div>
<div class="section" id="what-about-the-standard-c-library-headers">
<h2>3.2&nbsp;&nbsp;&nbsp;What about the standard C library headers?</h2>
-<p>C code almost always includes various header files from the standard C library, like <tt class="docutils literal"><span class="pre">stdio.h</span></tt>. While, with some effort, <tt class="docutils literal"><span class="pre">pycparser</span></tt> can be made to parse the standard headers from any C compiler, it's much simpler to use the provided &quot;fake&quot; standard in includes in <tt class="docutils literal"><span class="pre">utils/fake_libc_include</span></tt>. These are standard C header files that contain only the bare necessities to allow valid parsing of the files that use them. As a bonus, since they're minimal, it can significantly improve the performance of parsing C files.</p>
+<p>C code almost always includes various header files from the standard C library, like <tt class="docutils literal"><span class="pre">stdio.h</span></tt>. While, with some effort, <tt class="docutils literal"><span class="pre">pycparser</span></tt> can be made to parse the standard headers from any C compiler, it's much simpler to use the provided &quot;fake&quot; standard includes in <tt class="docutils literal"><span class="pre">utils/fake_libc_include</span></tt>. These are standard C header files that contain only the bare necessities to allow valid parsing of the files that use them. As a bonus, since they're minimal, it can significantly improve the performance of parsing C files.</p>
<p>See the <tt class="docutils literal"><span class="pre">using_cpp_libc.py</span></tt> example for more details.</p>
</div>
<div class="section" id="basic-usage">
@@ -463,6 +463,20 @@ ul.auto-toc {
<div class="section" id="changelog">
<h1>7&nbsp;&nbsp;&nbsp;Changelog</h1>
<ul class="simple">
+<li>Version 2.03 (06.03.2011)<ul>
+<li>Bug fixes:<ul>
+<li>Issue 17: empty file-level declarations</li>
+<li>Issue 18: empty statements and declarations in functions</li>
+<li>Issue 19: anonymous structs &amp; union fields</li>
+<li>Issue 23: fix coordinates of Cast nodes</li>
+</ul>
+</li>
+<li>New example added (<tt class="docutils literal"><span class="pre">examples/c-to-c.py</span></tt>) for translating ASTs generated by <tt class="docutils literal"><span class="pre">pycparser</span></tt> back into C code.</li>
+<li><tt class="docutils literal"><span class="pre">pycparser</span></tt> is now on PyPI (Python Package Index)</li>
+<li>Created <a class="reference external" href="http://code.google.com/p/pycparser/wiki/FAQ">FAQ</a> on the <tt class="docutils literal"><span class="pre">pycparser</span></tt> project page</li>
+<li>Removed support for Python 2.5. <tt class="docutils literal"><span class="pre">pycparser</span></tt> supports Python 2 from 2.6 and on, and Python 3.</li>
+</ul>
+</li>
<li>Version 2.02 (10.12.2010)<ul>
<li>The name of a <tt class="docutils literal"><span class="pre">NamedInitializer</span></tt> node was turned into a sequence of nodes
instead of an attribute, to make it discoverable by the AST node visitor.</li>
diff --git a/README.txt b/README.txt
index 9318211..3e7ae1f 100644
--- a/README.txt
+++ b/README.txt
@@ -1,5 +1,5 @@
===============
-pycparser v2.02
+pycparser v2.03
===============
:Author: `Eli Bendersky <http://eli.thegreenplace.net>`_
@@ -62,8 +62,8 @@ Installing
Prerequisites
-------------
-* ``pycparser`` was tested on Python 2.5, 2.6 and 3.1, on both Linux and Windows
-* ``pycparser`` uses the PLY module for the actual lexer and parser construction. Install PLY version 3.3 (earlier versions work at least since 2.5) from `its website <http://www.dabeaz.com/ply/>`_.
+* ``pycparser`` was tested on Python 2.6 and 3.2, on both Linux and Windows. It should work on any later version (in both the 2.x and 3.x lines) as well.
+* ``pycparser`` uses the PLY module for the actual lexer and parser construction. Install PLY from `its website <http://www.dabeaz.com/ply/>`_.
Installation process
--------------------
@@ -92,7 +92,7 @@ On the vast majority of Linux systems, ``cpp`` is installed and is in the PATH.
What about the standard C library headers?
------------------------------------------
-C code almost always includes various header files from the standard C library, like ``stdio.h``. While, with some effort, ``pycparser`` can be made to parse the standard headers from any C compiler, it's much simpler to use the provided "fake" standard in includes in ``utils/fake_libc_include``. These are standard C header files that contain only the bare necessities to allow valid parsing of the files that use them. As a bonus, since they're minimal, it can significantly improve the performance of parsing C files.
+C code almost always includes various header files from the standard C library, like ``stdio.h``. While, with some effort, ``pycparser`` can be made to parse the standard headers from any C compiler, it's much simpler to use the provided "fake" standard includes in ``utils/fake_libc_include``. These are standard C header files that contain only the bare necessities to allow valid parsing of the files that use them. As a bonus, since they're minimal, it can significantly improve the performance of parsing C files.
See the ``using_cpp_libc.py`` example for more details.
@@ -154,6 +154,20 @@ Some people have contributed to ``pycparser`` by opening issues on bugs they've
Changelog
=========
++ Version 2.03 (06.03.2011)
+
+ - Bug fixes:
+
+ * Issue 17: empty file-level declarations
+ * Issue 18: empty statements and declarations in functions
+ * Issue 19: anonymous structs & union fields
+ * Issue 23: fix coordinates of Cast nodes
+
+ - New example added (``examples/c-to-c.py``) for translating ASTs generated by ``pycparser`` back into C code.
+ - ``pycparser`` is now on PyPI (Python Package Index)
+ - Created `FAQ <http://code.google.com/p/pycparser/wiki/FAQ>`_ on the ``pycparser`` project page
+ - Removed support for Python 2.5. ``pycparser`` supports Python 2 from 2.6 and on, and Python 3.
+
+ Version 2.02 (10.12.2010)
* The name of a ``NamedInitializer`` node was turned into a sequence of nodes
diff --git a/TODO.txt b/TODO.txt
index 67f1a2e..340cb71 100644
--- a/TODO.txt
+++ b/TODO.txt
@@ -1,20 +1,6 @@
Todo
----
-* move changelist to wiki maybe?
-
-
-Fixes since last:
-------------------
-
-* Issue 17: empty file-level declarations
-* Issue 18: empty statements and declarations in functions
-* Issue 19: anonymous structs & union fields
-* Issue 23: fix coordinates of Cast nodes
-* pycparser is now on PyPI (Python Package Index)
-* Created FAQ on the pycparser project page - the readme now points to it
-* No support for Python 2.5, only starting with 2.6 and 3.x
-
Version Update
--------------
diff --git a/pycparser/__init__.py b/pycparser/__init__.py
index 9ee571e..c86b294 100644
--- a/pycparser/__init__.py
+++ b/pycparser/__init__.py
@@ -4,12 +4,12 @@
# This package file exports some convenience functions for
# interacting with pycparser
#
-# Copyright (C) 2008-2010, Eli Bendersky
+# Copyright (C) 2008-2011, Eli Bendersky
# License: LGPL
#-----------------------------------------------------------------
__all__ = ['c_lexer', 'c_parser', 'c_ast']
-__version__ = '2.02'
+__version__ = '2.03'
from subprocess import Popen, PIPE
diff --git a/setup.py b/setup.py
index 8cc88ac..ae36646 100644
--- a/setup.py
+++ b/setup.py
@@ -14,7 +14,7 @@ setup(
""",
install_requires=['ply'],
license='LGPL',
- version='2.02',
+ version='2.03',
author='Eli Bendersky',
maintainer='Eli Bendersky',
author_email='eliben@gmail.com',