summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDwayne C. Litzenberger <dlitz@dlitz.net>2008-09-13 00:13:29 -0400
committerDwayne C. Litzenberger <dlitz@dlitz.net>2008-09-13 00:30:29 -0400
commitd147ab526d370ef5a5be26db503b24fdb33ef581 (patch)
treef6f4b4b7afbb8d61b3b3b49489addc1b245995d4 /setup.py
parent5a9d81923333be5642371a9614f328297f8d09bc (diff)
downloadpycrypto-d147ab526d370ef5a5be26db503b24fdb33ef581.tar.gz
SelfTest: Add Crypto.SelfTest.Cipher and some tests
The RC5 implementation looks pretty buggy. It crashes if we give it one-byte keys, and the last few test vectors from RFC 2040 fail. Maybe I implemented something wrong, but I don't see where. Three cheers for patented algorithms! Hip hip, hooray! ;-P
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7d11b76..4520cc0 100644
--- a/setup.py
+++ b/setup.py
@@ -158,6 +158,7 @@ kw = {'name':"pycrypto",
'cmdclass' : {'build_ext':PCTBuildExt, 'build_py': PCTBuildPy},
'packages' : ["Crypto", "Crypto.Hash", "Crypto.Cipher", "Crypto.Util",
"Crypto.SelfTest",
+ "Crypto.SelfTest.Cipher",
"Crypto.SelfTest.Hash",
"Crypto.Protocol", "Crypto.PublicKey"],
'package_dir' : { "Crypto":"." },