summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Burke <tim.burke@gmail.com>2019-03-25 22:37:37 -0700
committerTim Burke <tim.burke@gmail.com>2019-03-25 22:38:17 -0700
commitcffa0e84cfdd43fd6c8118ad274c66e20d049ede (patch)
treee22fb0540d470040c46594131996021234f4623f
parentd12d90ea87710fb41a8a83da869a1290e9d6de27 (diff)
downloadpyeclib-cffa0e84cfdd43fd6c8118ad274c66e20d049ede.tar.gz
Prep for 1.6.0 release1.6.0
Change-Id: Iabd4989dc36e1754e60700f878dcfd25272529f3
-rw-r--r--AUTHORS7
-rw-r--r--ChangeLog7
-rw-r--r--doc/source/conf.py6
-rw-r--r--setup.py4
4 files changed, 18 insertions, 6 deletions
diff --git a/AUTHORS b/AUTHORS
index bba00a2..70e376e 100644
--- a/AUTHORS
+++ b/AUTHORS
@@ -5,18 +5,23 @@ Tushar Gohad (tushar.gohad@intel.com)
Contributors
------------
+Andreas Jaeger (aj@suse.com)
Clay Gerrard (clay.gerrard@gmail.com)
Davanum Srinivas (davanum@gmail.com)
Eric Lambert (eric_lambert@xyratex.com)
+Ian Wienand (iwienand@redhat.com)
+James E. Blair (jeblair@redhat.com)
Jim Cheung (jim.cheung@phazr.io)
John Dickinson (me@not.mn)
Kota Tsuyuzaki (bloodeagle40234@gmail.com)
Mark Storer (Mark.Storer@evault.com)
Ondřej Nový (ondrej.novy@firma.seznam.cz)
+Paul Belanger (pabelanger@redhat.com)
Pete Zaitcev (zaitcev@kotori.zaitcev.us)
Thiago da Silva (thiago@redhat.com)
-Timur Alperovich (timuralp@swiftstack.com)
Tim Burke (tim.burke@gmail.com)
+Timur Alperovich (timuralp@swiftstack.com)
+Tovin Seven (vinhnt@vn.fujitsu.com)
Victor Stinner (vstinner@redhat.com)
Yuan Zhou (yuan.zhou@intel.com)
diff --git a/ChangeLog b/ChangeLog
index 3ad5e89..e4472d2 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,10 @@
+New in 1.6.0
+------------
+
+ * Find liberasurecode in more environments
+ * Test against Python 3.7
+ * Test with more backends
+
New in 1.5.0
------------
diff --git a/doc/source/conf.py b/doc/source/conf.py
index 8d51341..1208b80 100644
--- a/doc/source/conf.py
+++ b/doc/source/conf.py
@@ -41,16 +41,16 @@ master_doc = 'index'
# General information about the project.
project = u'PyECLib'
-copyright = u'2016, Kevin Greenan, Tushar Gohad, Kota Tsuyuzaki'
+copyright = u'2019, Kevin Greenan, Tushar Gohad, Kota Tsuyuzaki'
# The version info for the project you're documenting, acts as replacement for
# |version| and |release|, also used in various other places throughout the
# built documents.
#
# The short X.Y version.
-version = '1.5.0'
+version = '1.6.0'
# The full version, including alpha/beta/rc tags.
-release = '1.5.0'
+release = '1.6.0'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/setup.py b/setup.py
index d205c0c..cf7e40b 100644
--- a/setup.py
+++ b/setup.py
@@ -210,7 +210,7 @@ class install(_install):
module = Extension('pyeclib_c',
define_macros=[('MAJOR VERSION', '1'),
- ('MINOR VERSION', '5')],
+ ('MINOR VERSION', '6')],
include_dirs=[default_python_incdir,
'src/c/pyeclib_c',
'/usr/include',
@@ -225,7 +225,7 @@ module = Extension('pyeclib_c',
sources=['src/c/pyeclib_c/pyeclib_c.c'])
setup(name='pyeclib',
- version='1.5.0',
+ version='1.6.0',
author='Kevin Greenan',
author_email='kmgreen2@gmail.com',
maintainer='Kevin Greenan and Tushar Gohad',