summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Pursehouse <david.pursehouse@sonymobile.com>2012-09-19 18:24:19 +0900
committerDavid Pursehouse <david.pursehouse@sonymobile.com>2012-09-20 13:54:22 +0900
commitfa27eb4280e2218caf50b9e613fa46335cdc2a13 (patch)
tree34aaba7f0bc82ab473905f3850cd21d674c55c59 /setup.py
parent1d741888256154832cfc74e055a9ad6b37eaaddc (diff)
downloadpygerrit-fa27eb4280e2218caf50b9e613fa46335cdc2a13.tar.gz
Add license information
Change-Id: I25ce3fafe7a51d0221f66fe30b2fb7cc8115c4aa
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py27
1 files changed, 26 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3752f1b..1723b37 100755
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,28 @@
-""" Client library for interacting with Gerrit. """
+""" Client library for interacting with Gerrit.
+
+The MIT License
+
+Copyright 2012 Sony Mobile Communications. All rights reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
+
+"""
from setuptools import setup
@@ -6,6 +30,7 @@ setup(
name="pygerrit",
description="Client library for interacting with Gerrit",
version="0.0.3",
+ license="The MIT License",
author="David Pursehouse",
author_email="david.pursehouse@sonymobile.com",
maintainer="David Pursehouse",