summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES6
-rw-r--r--README.rst10
-rw-r--r--doc/_static/github.pngbin0 -> 1127 bytes
-rw-r--r--doc/_templates/indexsidebar.html11
-rw-r--r--doc/docs/lexerdevelopment.rst6
-rw-r--r--doc/download.rst14
-rw-r--r--doc/faq.rst4
-rw-r--r--doc/index.rst10
-rw-r--r--pygments/__init__.py6
-rw-r--r--pygments/cmdline.py2
-rw-r--r--scripts/release-checklist10
11 files changed, 36 insertions, 43 deletions
diff --git a/CHANGES b/CHANGES
index 4d87e121..650e09f6 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,10 +1,10 @@
Pygments changelog
==================
-Issue numbers refer to the tracker at
-<https://bitbucket.org/birkenfeld/pygments-main/issues>,
+Since 2.5.0, issue numbers refer to the tracker at
+<https://github.com/pygments/pygments/issues>,
pull request numbers to the requests at
-<https://bitbucket.org/birkenfeld/pygments-main/pull-requests/merged>.
+<https://github.com/pygments/pygments/pulls>.
Version 2.5.0
-------------
diff --git a/README.rst b/README.rst
index 350e242e..507e416c 100644
--- a/README.rst
+++ b/README.rst
@@ -21,14 +21,14 @@ Documentation
Development
-----------
-... takes place on `Bitbucket
-<https://bitbucket.org/birkenfeld/pygments-main>`_, where the Mercurial
+... takes place on `GitHub
+<https://github.com/pygments/pygments>`_, where the Git
repository, tickets and pull requests can be viewed.
-Continuous testing runs on drone.io:
+Continuous testing runs on GitHub workflows:
-.. image:: https://drone.io/bitbucket.org/birkenfeld/pygments-main/status.png
- :target: https://drone.io/bitbucket.org/birkenfeld/pygments-main
+.. image:: https://github.com/pygments/pygments/workflows/Pygments/badge.svg
+ :target: https://github.com/pygments/pygments/actions?query=workflow%3APygments
The authors
-----------
diff --git a/doc/_static/github.png b/doc/_static/github.png
new file mode 100644
index 00000000..5d146adc
--- /dev/null
+++ b/doc/_static/github.png
Binary files differ
diff --git a/doc/_templates/indexsidebar.html b/doc/_templates/indexsidebar.html
index 50653d75..5544f98a 100644
--- a/doc/_templates/indexsidebar.html
+++ b/doc/_templates/indexsidebar.html
@@ -3,8 +3,8 @@
<p>This documentation is for version <b>{{ version }}</b>, which is
not released yet.</p>
<p>You can use it from the
- <a href="http://bitbucket.org/birkenfeld/sphinx/">Mercurial repo</a> or look for
- released versions in the <a href="http://pypi.python.org/pypi/Sphinx">Python
+ <a href="http://github.com/pygments/pygments/">Git repo</a> or look for
+ released versions in the <a href="http://pypi.python.org/pypi/Pygments">Python
Package Index</a>.</p>
{% else %}
<p>Current version: <b>{{ version }}</b></p>
@@ -15,9 +15,10 @@
<h3>Questions? Suggestions?</h3>
-<p>Clone at <a href="https://bitbucket.org/birkenfeld/pygments-main">Bitbucket</a></p>
+<p><img src="{{ pathto("_static/github.png", 1) }}" width="24" />
+ Clone at <a href="https://github.com/pygments/pygments">GitHub</a>.</p>
<p>You can also open an issue at the
- <a href="https://www.bitbucket.org/birkenfeld/pygments-main/issues/">tracker</a>.</p>
+ <a href="https://github.com/pygments/pygments/issues">tracker</a>.</p>
<p class="logo">A <a href="http://pocoo.org/">
- <img src="{{ pathto("_static/pocoo.png", 1) }}" /></a> project</a></p> \ No newline at end of file
+ <img src="{{ pathto("_static/pocoo.png", 1) }}" /></a> project</a></p>
diff --git a/doc/docs/lexerdevelopment.rst b/doc/docs/lexerdevelopment.rst
index 63bd01a3..5b6813fb 100644
--- a/doc/docs/lexerdevelopment.rst
+++ b/doc/docs/lexerdevelopment.rst
@@ -136,7 +136,7 @@ have to perform the following steps.
First, change to the current directory containing the Pygments source code. You
will need to have either an unpacked source tarball, or (preferably) a copy
-cloned from BitBucket.
+cloned from GitHub.
.. code-block:: console
@@ -611,7 +611,7 @@ possibility to influence the position.
There are not really any simple examples for lexer callbacks, but you can see
them in action e.g. in the `SMLLexer` class in `ml.py`_.
-.. _ml.py: http://bitbucket.org/birkenfeld/pygments-main/src/tip/pygments/lexers/ml.py
+.. _ml.py: https://github.com/pygments/pygments/blob/master/pygments/lexers/ml.py
The ExtendedRegexLexer class
@@ -667,7 +667,7 @@ For example, this is how the hypothetical lexer above would be written with the
This might sound confusing (and it can really be). But it is needed, and for an
example look at the Ruby lexer in `ruby.py`_.
-.. _ruby.py: https://bitbucket.org/birkenfeld/pygments-main/src/tip/pygments/lexers/ruby.py
+.. _ruby.py: https://github.com/pygments/pygments/blob/master/pygments/lexers/ruby.py
Handling Lists of Keywords
diff --git a/doc/download.rst b/doc/download.rst
index cf32f481..975c41b0 100644
--- a/doc/download.rst
+++ b/doc/download.rst
@@ -18,17 +18,15 @@ manager as usual.
Development sources
-------------------
-We're using the `Mercurial <http://selenic.com/mercurial>`_ version control
-system. You can get the development source using this command::
+We're using the Git version control system. You can get the development source
+using this command::
- hg clone http://bitbucket.org/birkenfeld/pygments-main pygments
+ git clone https://github.com/pygments/pygments
-Development takes place at `Bitbucket
-<http://bitbucket.org/birkenfeld/pygments-main>`_, you can browse the source
-online `here <http://bitbucket.org/birkenfeld/pygments-main/src>`_.
+Development takes place at `GitHub <https://github.com/pygments/pygments>`_.
The latest changes in the development source code are listed in the `changelog
-<http://bitbucket.org/birkenfeld/pygments-main/src/tip/CHANGES>`_.
+<https://github.com/pygments/pygments/blob/master/CHANGES>`_.
.. Documentation
-------------
@@ -36,6 +34,6 @@ The latest changes in the development source code are listed in the `changelog
.. XXX todo
You can download the <a href="/docs/">documentation</a> either as
- a bunch of rst files from the Mercurial repository, see above, or
+ a bunch of rst files from the Git repository, see above, or
as a tar.gz containing rendered HTML files:</p>
<p><a href="/docs/download/pygmentsdocs.tar.gz">pygmentsdocs.tar.gz</a></p>
diff --git a/doc/faq.rst b/doc/faq.rst
index 172929e0..28db1d2a 100644
--- a/doc/faq.rst
+++ b/doc/faq.rst
@@ -62,9 +62,9 @@ Please see the :doc:`documentation on styles <docs/styles>`.
How can I report a bug or suggest a feature?
--------------------------------------------
-Please report bugs and feature wishes in the tracker at Bitbucket.
+Please report bugs and feature wishes in the tracker at GitHub.
-You can also e-mail the author or use IRC, see the contact details.
+You can also e-mail the authors, see the contact details.
I want this support for this language!
--------------------------------------
diff --git a/doc/index.rst b/doc/index.rst
index 26114045..3a2d88c9 100644
--- a/doc/index.rst
+++ b/doc/index.rst
@@ -26,15 +26,9 @@ Like every open-source project, we are always looking for volunteers to help us
with programming. Python knowledge is required, but don't fear: Python is a very
clear and easy to learn language.
-Development takes place on `Bitbucket
-<https://bitbucket.org/birkenfeld/pygments-main>`_, where the Mercurial
-repository, tickets and pull requests can be viewed.
+Development takes place on `GitHub <https://github.com/pygments/pygments>`_.
-Our primary communication instrument is the IRC channel **#pocoo** on the
-Freenode network. To join it, let your IRC client connect to
-``irc.freenode.net`` and do ``/join #pocoo``.
-
-If you found a bug, just open a ticket in the Bitbucket tracker. Be sure to log
+If you found a bug, just open a ticket in the GitHub tracker. Be sure to log
in to be notified when the issue is fixed -- development is not fast-paced as
the library is quite stable. You can also send an e-mail to the developers, see
below.
diff --git a/pygments/__init__.py b/pygments/__init__.py
index 15c226a3..ffe36033 100644
--- a/pygments/__init__.py
+++ b/pygments/__init__.py
@@ -17,10 +17,10 @@
* it is usable as a command-line tool and as a library
* ... and it highlights even Brainfuck!
- The `Pygments tip`_ is installable with ``easy_install Pygments==dev``.
+ The `Pygments master branch`_ is installable with ``easy_install Pygments==dev``.
- .. _Pygments tip:
- http://bitbucket.org/birkenfeld/pygments-main/get/tip.zip#egg=Pygments-dev
+ .. _Pygments master branch:
+ https://github.com/pygments/pygments/archive/master.zip#egg=Pygments-dev
:copyright: Copyright 2006-2019 by the Pygments team, see AUTHORS.
:license: BSD, see LICENSE for details.
diff --git a/pygments/cmdline.py b/pygments/cmdline.py
index 292cb870..34752d66 100644
--- a/pygments/cmdline.py
+++ b/pygments/cmdline.py
@@ -554,7 +554,7 @@ def main(args=sys.argv):
file=sys.stderr)
print('Please report the whole traceback to the issue tracker at',
file=sys.stderr)
- print('<https://bitbucket.org/birkenfeld/pygments-main/issues>.',
+ print('<https://github.com/pygments/pygments/issues>.',
file=sys.stderr)
print('*' * 65, file=sys.stderr)
print(file=sys.stderr)
diff --git a/scripts/release-checklist b/scripts/release-checklist
index efc1e1e8..f1bd0f38 100644
--- a/scripts/release-checklist
+++ b/scripts/release-checklist
@@ -1,24 +1,24 @@
Release checklist
=================
-* Check ``hg status``
+* Check ``git status``
* ``make check``
* LATER when configured properly: ``make pylint``
* ``tox``
* Update version info in ``setup.py/__init__.py``
* Check setup.py metadata: long description, trove classifiers
* Update release date/code name in ``CHANGES``
-* ``hg commit``
+* ``git commit``
* ``make clean``
* ``python2 setup.py release bdist_wheel``
* ``python3 setup.py release bdist_wheel sdist``
* ``twine upload dist/Pygments-$NEWVER*``
* Check PyPI release page for obvious errors
-* ``hg tag``
+* ``git tag -a``
* Merge default into stable if this was a ``x.y.0``
* Update homepage (release info), regenerate docs (+printable!)
* Add new version/milestone to tracker categories
* Write announcement and send to mailing list/python-announce
* Update version info, add new ``CHANGES`` entry for next version
-* ``hg commit``
-* ``hg push``
+* ``git commit``
+* ``git push``