summaryrefslogtreecommitdiff
path: root/scripts/release-checklist
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/release-checklist')
-rw-r--r--scripts/release-checklist10
1 files changed, 5 insertions, 5 deletions
diff --git a/scripts/release-checklist b/scripts/release-checklist
index efc1e1e8..f1bd0f38 100644
--- a/scripts/release-checklist
+++ b/scripts/release-checklist
@@ -1,24 +1,24 @@
Release checklist
=================
-* Check ``hg status``
+* Check ``git status``
* ``make check``
* LATER when configured properly: ``make pylint``
* ``tox``
* Update version info in ``setup.py/__init__.py``
* Check setup.py metadata: long description, trove classifiers
* Update release date/code name in ``CHANGES``
-* ``hg commit``
+* ``git commit``
* ``make clean``
* ``python2 setup.py release bdist_wheel``
* ``python3 setup.py release bdist_wheel sdist``
* ``twine upload dist/Pygments-$NEWVER*``
* Check PyPI release page for obvious errors
-* ``hg tag``
+* ``git tag -a``
* Merge default into stable if this was a ``x.y.0``
* Update homepage (release info), regenerate docs (+printable!)
* Add new version/milestone to tracker categories
* Write announcement and send to mailing list/python-announce
* Update version info, add new ``CHANGES`` entry for next version
-* ``hg commit``
-* ``hg push``
+* ``git commit``
+* ``git push``