summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2022-07-30 10:53:53 +0200
committerGitHub <noreply@github.com>2022-07-30 10:53:53 +0200
commit4117389b991ad814588a8d11c53a5f99b14c6b42 (patch)
tree5e4bccee0d8fa90fbb283287fe3e6e484661428f
parent36a6723ce6b15e8a466a300b6594d6828305fd67 (diff)
downloadpylint-git-4117389b991ad814588a8d11c53a5f99b14c6b42.tar.gz
[doc] Remove hard-coded default in 'ignored-argument-names' description (#7239)
-rw-r--r--doc/user_guide/configuration/all-options.rst2
-rw-r--r--examples/pylintrc3
-rw-r--r--examples/pyproject.toml3
-rw-r--r--pylint/checkers/variables.py3
4 files changed, 4 insertions, 7 deletions
diff --git a/doc/user_guide/configuration/all-options.rst b/doc/user_guide/configuration/all-options.rst
index e1ebaca25..41b58efba 100644
--- a/doc/user_guide/configuration/all-options.rst
+++ b/doc/user_guide/configuration/all-options.rst
@@ -1523,7 +1523,7 @@ Standard Checkers
--ignored-argument-names
""""""""""""""""""""""""
-*Argument names that match this expression will be ignored. Default to name with leading underscore.*
+*Argument names that match this expression will be ignored.*
**Default:** ``re.compile('_.*|^ignored_|^unused_')``
diff --git a/examples/pylintrc b/examples/pylintrc
index d3f27833b..24fce68d2 100644
--- a/examples/pylintrc
+++ b/examples/pylintrc
@@ -468,8 +468,7 @@ callbacks=cb_,
# not be used).
dummy-variables-rgx=_+$|(_[a-zA-Z0-9_]*[a-zA-Z0-9]+?$)|dummy|^ignored_|^unused_
-# Argument names that match this expression will be ignored. Default to name
-# with leading underscore.
+# Argument names that match this expression will be ignored.
ignored-argument-names=_.*|^ignored_|^unused_
# Tells whether we should check for unused import in __init__ files.
diff --git a/examples/pyproject.toml b/examples/pyproject.toml
index 4147184a8..061ddaf22 100644
--- a/examples/pyproject.toml
+++ b/examples/pyproject.toml
@@ -509,8 +509,7 @@ callbacks = ["cb_", "_cb"]
# be used).
dummy-variables-rgx = "_+$|(_[a-zA-Z0-9_]*[a-zA-Z0-9]+?$)|dummy|^ignored_|^unused_"
-# Argument names that match this expression will be ignored. Default to name with
-# leading underscore.
+# Argument names that match this expression will be ignored.
ignored-argument-names = "_.*|^ignored_|^unused_"
# Tells whether we should check for unused import in __init__ files.
diff --git a/pylint/checkers/variables.py b/pylint/checkers/variables.py
index 9ec921200..0cdd37c5e 100644
--- a/pylint/checkers/variables.py
+++ b/pylint/checkers/variables.py
@@ -1056,8 +1056,7 @@ class VariablesChecker(BaseChecker):
"default": IGNORED_ARGUMENT_NAMES,
"type": "regexp",
"metavar": "<regexp>",
- "help": "Argument names that match this expression will be "
- "ignored. Default to name with leading underscore.",
+ "help": "Argument names that match this expression will be ignored.",
},
),
(