summaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
authorPierre Sassoulas <pierre.sassoulas@gmail.com>2022-07-30 15:15:44 +0200
committerGitHub <noreply@github.com>2022-07-30 15:15:44 +0200
commit9e17a6dbf0a43511ddaf5c36de83e3d09629437e (patch)
tree663e26b062126a80c0fa5d67d2dcdc3e490a1694 /examples
parent90884856a3e2c3531d678a31a4455270a75bc6c7 (diff)
downloadpylint-git-9e17a6dbf0a43511ddaf5c36de83e3d09629437e.tar.gz
Bump pylint to 2.15.0-a0, update changelog (#7196)
[doc] Add summary for the release notes
Diffstat (limited to 'examples')
-rw-r--r--examples/pylintrc19
-rw-r--r--examples/pyproject.toml16
2 files changed, 26 insertions, 9 deletions
diff --git a/examples/pylintrc b/examples/pylintrc
index 24fce68d2..a955c56ed 100644
--- a/examples/pylintrc
+++ b/examples/pylintrc
@@ -44,13 +44,15 @@ fail-under=10
# Files or directories to be skipped. They should be base names, not paths.
ignore=CVS
-# Add files or directories matching the regex patterns to the ignore-list. The
-# regex matches against paths and can be in Posix or Windows format.
+# Add files or directories matching the regular expressions patterns to the
+# ignore-list. The regex matches against paths and can be in Posix or Windows
+# format. Because '\' represents the directory delimiter on Windows systems, it
+# can't be used as an escape character.
ignore-paths=
-# Files or directories matching the regex patterns are skipped. The regex
-# matches against base names, not paths. The default value ignores Emacs file
-# locks
+# Files or directories matching the regular expression patterns are skipped.
+# The regex matches against base names, not paths. The default value ignores
+# Emacs file locks
ignore-patterns=^\.#
# List of module names for which member attributes should not be checked
@@ -160,6 +162,13 @@ disable=raw-checker-failed,
enable=c-extension-no-member
+[METHOD_ARGS]
+
+# List of qualified names (i.e., library.method) which require a timeout
+# parameter e.g. 'requests.api.get,requests.api.post'
+timeout-methods=requests.api.delete,requests.api.get,requests.api.head,requests.api.options,requests.api.patch,requests.api.post,requests.api.put,requests.api.request
+
+
[EXCEPTIONS]
# Exceptions that will emit a warning when caught.
diff --git a/examples/pyproject.toml b/examples/pyproject.toml
index 061ddaf22..b419f83e7 100644
--- a/examples/pyproject.toml
+++ b/examples/pyproject.toml
@@ -34,12 +34,15 @@ fail-under = 10
# Files or directories to be skipped. They should be base names, not paths.
ignore = ["CVS"]
-# Add files or directories matching the regex patterns to the ignore-list. The
-# regex matches against paths and can be in Posix or Windows format.
+# Add files or directories matching the regular expressions patterns to the
+# ignore-list. The regex matches against paths and can be in Posix or Windows
+# format. Because '\' represents the directory delimiter on Windows systems, it
+# can't be used as an escape character.
# ignore-paths =
-# Files or directories matching the regex patterns are skipped. The regex matches
-# against base names, not paths. The default value ignores Emacs file locks
+# Files or directories matching the regular expression patterns are skipped. The
+# regex matches against base names, not paths. The default value ignores Emacs
+# file locks
ignore-patterns = ["^\\.#"]
# List of module names for which member attributes should not be checked (useful
@@ -353,6 +356,11 @@ disable = ["raw-checker-failed", "bad-inline-option", "locally-disabled", "file-
# should appear only once). See also the "--disable" option for examples.
enable = ["c-extension-no-member"]
+[tool.pylint.method_args]
+# List of qualified names (i.e., library.method) which require a timeout
+# parameter e.g. 'requests.api.get,requests.api.post'
+timeout-methods = ["requests.api.delete", "requests.api.get", "requests.api.head", "requests.api.options", "requests.api.patch", "requests.api.post", "requests.api.put", "requests.api.request"]
+
[tool.pylint.miscellaneous]
# List of note tags to take in consideration, separated by a comma.
notes = ["FIXME", "XXX", "TODO"]