summaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
authorSamuel FORESTIER <HorlogeSkynet@users.noreply.github.com>2023-03-11 21:55:17 +0000
committerGitHub <noreply@github.com>2023-03-11 22:55:17 +0100
commitb312b9a66472e17d02461258d2156d670481a7f6 (patch)
tree819e3ffed71e6886b0b229554daad80d9f161aa0 /examples
parent4c56ba82d7aac50b1ea34e929833c91418e1d117 (diff)
downloadpylint-git-b312b9a66472e17d02461258d2156d670481a7f6.tar.gz
Add Python 3.8+ `asyncSetUp` to "defining-attr-methods" list (#8403)
Diffstat (limited to 'examples')
-rw-r--r--examples/pylintrc1
-rw-r--r--examples/pyproject.toml2
2 files changed, 2 insertions, 1 deletions
diff --git a/examples/pylintrc b/examples/pylintrc
index 70c5ff87c..16284083e 100644
--- a/examples/pylintrc
+++ b/examples/pylintrc
@@ -260,6 +260,7 @@ check-protected-access-in-special-methods=no
defining-attr-methods=__init__,
__new__,
setUp,
+ asyncSetUp,
__post_init__
# List of member names, which should be excluded from the protected access
diff --git a/examples/pyproject.toml b/examples/pyproject.toml
index 1608d2cbb..f9a493c89 100644
--- a/examples/pyproject.toml
+++ b/examples/pyproject.toml
@@ -226,7 +226,7 @@ variable-naming-style = "snake_case"
# check-protected-access-in-special-methods =
# List of method names used to declare (i.e. assign) instance attributes.
-defining-attr-methods = ["__init__", "__new__", "setUp", "__post_init__"]
+defining-attr-methods = ["__init__", "__new__", "setUp", "asyncSetUp", "__post_init__"]
# List of member names, which should be excluded from the protected access
# warning.