summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniƫl van Noord <13665637+DanielNoord@users.noreply.github.com>2023-03-08 19:45:52 +0100
committerGitHub <noreply@github.com>2023-03-08 19:45:52 +0100
commitac5f0a4176532a459f0c4c0b6289c43f94994489 (patch)
tree3d1e350df0c90cc490249f6d70255511c8421b3b /pyproject.toml
parent1ed1ab03abd90b87514f07a6b67cfd090ff518e2 (diff)
downloadpylint-git-ac5f0a4176532a459f0c4c0b6289c43f94994489.tar.gz
Add and expose ``py.typed`` (#8402)
Co-authored-by: Pierre Sassoulas <pierre.sassoulas@gmail.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 0c2b2a817..e5ab0d735 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -30,6 +30,7 @@ classifiers = [
"Topic :: Software Development :: Debuggers",
"Topic :: Software Development :: Quality Assurance",
"Topic :: Software Development :: Testing",
+ "Typing :: Typed"
]
requires-python = ">=3.7.2"
dependencies = [
@@ -75,7 +76,7 @@ license-files = ["LICENSE", "CONTRIBUTORS.txt"] # Keep in sync with setup.cfg
include = ["pylint*"]
[tool.setuptools.package-data]
-pylint = ["testutils/testing_pylintrc"]
+pylint = ["testutils/testing_pylintrc", "py.typed"]
[tool.setuptools.dynamic]
version = {attr = "pylint.__pkginfo__.__version__"}