summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmile Anclin <emile.anclin@logilab.fr>2010-03-23 12:33:59 +0100
committerEmile Anclin <emile.anclin@logilab.fr>2010-03-23 12:33:59 +0100
commit47e4bb375747c006595e7f6169761bb61e39f1dd (patch)
tree07115656fe028f7012c1674c8cec900710138117
parente5e6118c1065720528b7d9f153476a3caecbcf92 (diff)
downloadpylint-47e4bb375747c006595e7f6169761bb61e39f1dd.tar.gz
fix #19498: apply windows batch patch
-rw-r--r--bin/epylint.bat19
-rw-r--r--bin/pylint-gui.bat23
-rw-r--r--bin/pylint.bat23
-rw-r--r--bin/pyreverse.bat21
-rw-r--r--bin/symilar.bat23
-rw-r--r--setup.py3
6 files changed, 22 insertions, 90 deletions
diff --git a/bin/epylint.bat b/bin/epylint.bat
index a506782..81d4e18 100644
--- a/bin/epylint.bat
+++ b/bin/epylint.bat
@@ -1,16 +1,5 @@
@echo off
-rem = """-*-Python-*- script
-rem -------------------- DOS section --------------------
-rem You could set PYTHONPATH or TK environment variables here
-python -x "%~f0" %*
-goto exit
-
-"""
-# -------------------- Python section --------------------
-from pylint import epylint
-epylint.Run()
-
-
-DosExitLabel = """
-:exit
-rem """
+rem Use python to execute the python script having the same name as this batch
+rem file, but without any extension, located in the same directory as this
+rem batch file
+python "%~dpn0" %*
diff --git a/bin/pylint-gui.bat b/bin/pylint-gui.bat
index b721e5c..88e566b 100644
--- a/bin/pylint-gui.bat
+++ b/bin/pylint-gui.bat
@@ -1,20 +1,5 @@
@echo off
-rem = """-*-Python-*- script
-@echo off
-rem -------------------- DOS section --------------------
-rem You could set PYTHONPATH or TK environment variables here
-python -x "%~f0" %*
-goto exit
-
-"""
-# -------------------- Python section --------------------
-import sys
-from pylint import gui
-gui.Run(sys.argv[1:])
-
-
-DosExitLabel = """
-:exit
-rem """
-
-
+rem Use python to execute the python script having the same name as this batch
+rem file, but without any extension, located in the same directory as this
+rem batch file
+python "%~dpn0" %*
diff --git a/bin/pylint.bat b/bin/pylint.bat
index 3239fc5..88e566b 100644
--- a/bin/pylint.bat
+++ b/bin/pylint.bat
@@ -1,20 +1,5 @@
@echo off
-rem = """-*-Python-*- script
-rem -------------------- DOS section --------------------
-rem You could set PYTHONPATH or TK environment variables here
-python -x "%~f0" %*
-goto exit
-
-"""
-# -------------------- Python section --------------------
-import sys
-from pylint import lint
-lint.Run(sys.argv[1:])
-
-
-DosExitLabel = """
-:exit
-exit(ERRORLEVEL)
-rem """
-
-
+rem Use python to execute the python script having the same name as this batch
+rem file, but without any extension, located in the same directory as this
+rem batch file
+python "%~dpn0" %*
diff --git a/bin/pyreverse.bat b/bin/pyreverse.bat
index f131302..81d4e18 100644
--- a/bin/pyreverse.bat
+++ b/bin/pyreverse.bat
@@ -1,18 +1,5 @@
@echo off
-rem = """-*-Python-*- script
-@echo off
-rem -------------------- DOS section --------------------
-rem You could set PYTHONPATH or TK environment variables here
-python -x "%~f0" %*
-goto exit
-
-"""
-# -------------------- Python section --------------------
-import sys
-from pylint.pyreverse import main
-main.Run(sys.argv[1:])
-
-
-DosExitLabel = """
-:exit
-rem """
+rem Use python to execute the python script having the same name as this batch
+rem file, but without any extension, located in the same directory as this
+rem batch file
+python "%~dpn0" %*
diff --git a/bin/symilar.bat b/bin/symilar.bat
index 24e339e..88e566b 100644
--- a/bin/symilar.bat
+++ b/bin/symilar.bat
@@ -1,20 +1,5 @@
@echo off
-rem = """-*-Python-*- script
-@echo off
-rem -------------------- DOS section --------------------
-rem You could set PYTHONPATH or TK environment variables here
-python -x "%~f0" %*
-goto exit
-
-"""
-# -------------------- Python section --------------------
-import sys
-from pylint.checkers import similar
-similar.run()
-
-
-DosExitLabel = """
-:exit
-rem """
-
-
+rem Use python to execute the python script having the same name as this batch
+rem file, but without any extension, located in the same directory as this
+rem batch file
+python "%~dpn0" %*
diff --git a/setup.py b/setup.py
index 9e7308a..92e8310 100644
--- a/setup.py
+++ b/setup.py
@@ -63,7 +63,8 @@ def ensure_scripts(linux_scripts):
"""
from distutils import util
if util.get_platform()[:3] == 'win':
- scripts_ = [script + '.bat' for script in linux_scripts]
+ scripts_ = linux_scripts + [script + '.bat'
+ for script in linux_scripts]
else:
scripts_ = linux_scripts
return scripts_