summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Jehannet <julien.jehannet@logilab.fr>2010-05-25 12:17:41 +0200
committerJulien Jehannet <julien.jehannet@logilab.fr>2010-05-25 12:17:41 +0200
commitac26c4837312e34164d4d3ff03c848b5278dce53 (patch)
treed8541f108a5e094a679042625ebe1c1c322a0306
parent09613a6526fc4801e5457f318cdeeeadced568ec (diff)
downloadpylint-ac26c4837312e34164d4d3ff03c848b5278dce53.tar.gz
pkginfo: minor changes to stick to new policy
-rw-r--r--__pkginfo__.py2
-rw-r--r--debian/changelog3
-rw-r--r--setup.py4
3 files changed, 5 insertions, 4 deletions
diff --git a/__pkginfo__.py b/__pkginfo__.py
index 2fd6ddd..12f1766 100644
--- a/__pkginfo__.py
+++ b/__pkginfo__.py
@@ -46,7 +46,7 @@ classifiers = ['Development Status :: 4 - Beta',
]
-short_desc = "python code static checker"
+description = "python code static checker"
long_desc = """\
Pylint is a Python source code analyzer which looks for programming
errors, helps enforcing a coding standard and sniffs for some code
diff --git a/debian/changelog b/debian/changelog
index bececbd..2ba0dad 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,6 @@
pylint (0.21.0-2) unstable; urgency=low
+ [ Sylvain Thénault ]
* update man-page according to 0.21 usage (Closes: #582494)
--
@@ -30,7 +31,7 @@ pylint (0.18.1-1) unstable; urgency=low
-- Sylvain Thénault <sylvain.thenault@logilab.fr> Thu, 27 Aug 2009 08:37:00 +0200
-pylint (0.18.0-2) UNRELEASED; urgency=low
+pylint (0.18.0-2) unstable; urgency=low
* Python transition, thanks Alessio Treglia for the patch (Closes: #530509)
- Use --install-layout=deb for setup.py install.
diff --git a/setup.py b/setup.py
index 18a7abb..4a07641 100644
--- a/setup.py
+++ b/setup.py
@@ -27,7 +27,7 @@ except ImportError:
sys.modules.pop('__pkginfo__', None)
# import required features
-from __pkginfo__ import modname, version, license, short_desc, long_desc, \
+from __pkginfo__ import modname, version, license, description, long_desc, \
web, author, author_email, classifiers
# import optional features
try:
@@ -129,7 +129,7 @@ def install(**kwargs):
return setup(name = distname,
version = version,
license = license,
- description = short_desc,
+ description = description,
long_description = long_desc,
author = author,
author_email = author_email,