summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSylvain Th?nault <sylvain.thenault@logilab.fr>2013-04-16 15:05:58 +0200
committerSylvain Th?nault <sylvain.thenault@logilab.fr>2013-04-16 15:05:58 +0200
commitcaf3f7c8f1549628f6fb6b6a273481c4e9ca3e9d (patch)
treee20a727f70df0e7b50d4f3de1c88fb1691b45bf0
parent527875588091b8f50ffcee91b0cfd7fcb99873e1 (diff)
downloadpylint-caf3f7c8f1549628f6fb6b6a273481c4e9ca3e9d.tar.gz
Moving development to bitbucket. Rephrase README on the way
-rw-r--r--README46
-rw-r--r--doc/FAQ.txt4
-rw-r--r--doc/manual.txt17
3 files changed, 36 insertions, 31 deletions
diff --git a/README b/README
index c1d0af3..89ce088 100644
--- a/README
+++ b/README
@@ -1,16 +1,33 @@
README for Pylint (http://www.pylint.org)
=========================================
-Dependencies
-------------
-Pylint requires the logilab-astng (version >= 0.21.0), logilab-common
-(version >= 0.53).
+Pylint is a Python source code analyzer which looks for programming errors,
+helps enforcing a coding standard and sniffs for some code smells (as defined in
+Martin Fowler's Refactoring book).
+
+Pylint has many rules enabled by default, way too much to silent them all on a
+minimally sized program. It's highly configurable and handle pragmas to control
+it from within your code. Additionally, it is possible to write plugins to add
+your own checks.
+
+It's a free software distributed under the GNU Public Licence.
+
+Development is hosted on bitbucket: https://bitbucket.org/logilab/pylint/ .
+
+You can use the python-projects@logilab.org mailing list to discuss about
+Pylint. Subscribe at http://lists.logilab.org/mailman/listinfo/python-projects
+or read the archives at http://lists.logilab.org/pipermail/python-projects/
-* http://www.logilab.org/projects/astng
-* http://www.logilab.org/projects/common
Install
-------
+
+Pylint requires the astng (the later the better) and logilab-common (version >=
+0.53) packages.
+
+* https://bitbucket.org/logilab/astng
+* http://www.logilab.org/projects/common
+
From the source distribution, extract the tarball and run ::
python setup.py install
@@ -21,10 +38,11 @@ rpm packages, use your usual tools according to your Linux distribution.
More information about installation and available distribution format
may be found in the user manual in the *doc* subdirectory.
+
Documentation
-------------
-Look in the doc/ subdirectory or at the project home page
-http://www.logilab.org/project/pylint
+
+Look in the doc/ subdirectory or at http://docs.pylint.org
Pylint is shipped with following additional commands:
@@ -33,18 +51,6 @@ Pylint is shipped with following additional commands:
* epylint: Emacs and Flymake compatible Pylint
* pylint-gui: a graphical interface
-Comments, support, bug reports
-------------------------------
-
-Project page and tracker on :
-http://www.logilab.org/project/pylint
-
-Use the python-projects@logilab.org mailing list.
-You can subscribe to this mailing list at
-http://lists.logilab.org/mailman/listinfo/python-projects
-
-Archives are available at
-http://lists.logilab.org/pipermail/python-projects/
Contributors
------------
diff --git a/doc/FAQ.txt b/doc/FAQ.txt
index 5fc68e5..e2bb213 100644
--- a/doc/FAQ.txt
+++ b/doc/FAQ.txt
@@ -85,7 +85,7 @@ Pylint uses the Mercurial_ distributed version control system. The URL of the
repository is: https://bitbucket.org/logilab/pylint. To get the latest version of
Pylint from the repository, simply invoke ::
- hg clone http://www.logilab.org/hg/pylint
+ hg clone https://bitbucket.org/logilab/pylint
.. _Mercurial: http://mercurial.selenic.com/
@@ -95,7 +95,7 @@ Pylint from the repository, simply invoke ::
Pylint requires the latest `astng`_ and `logilab-common`_ packages. It should be
compatible with any python version greater than 2.5.0.
-.. _`logilab-astng`: http://www.logilab.org/project/logilab-astng
+.. _`astng`: https://bitbucket.org/logilab/astng
.. _`logilab-common`: http://www.logilab.org/project/logilab-common
diff --git a/doc/manual.txt b/doc/manual.txt
index 4909e46..158aade 100644
--- a/doc/manual.txt
+++ b/doc/manual.txt
@@ -63,7 +63,7 @@ Dependencies
Pylint requires the latest `astng`_ and `logilab-common`_
packages. It should be compatible with any python version >= 2.5.
-.. _`logilab-astng`: http://www.logilab.org/project/name/astng
+.. _`astng`: https://bitbucket.org/logilab/astng
.. _`logilab-common`: http://www.logilab.org/project/name/common
@@ -373,17 +373,17 @@ the `tracker page`_. This mailing list is also a nice place to
discuss Pylint issues, see below for more information about Pylint's related
lists.
-You can check for already reported bugs, planned features on pylint's tracker
-web page: http://www.logilab.org/project/name/pylint
+You can check for already reported bugs, planned features on Pylint's tracker
+web page: https://bitbucket.org/logilab/pylint/issues
Notice that if you don't find something you have expected in Pylint's
tracker page, it may be on the tracker page of one of its dependencies, namely
astng and common:
-* http://www.logilab.org/project/name/logilab-astng
+* https://bitbucket.org/logilab/astng/issues
* http://www.logilab.org/project/name/logilab-common
-.. _`tracker page`: http://www.logilab.org/project/name/pylint
+.. _`tracker page`: https://bitbucket.org/logilab/pylint/issues
Mailing lists
-------------
@@ -582,16 +582,15 @@ some different usage patterns). See mercurial home page for installation on
your computer and basic usage. Note that it's very easy to send us patches using
`hg email` command ;).
-You can get the in-development pylint source code from our public mercurial_
-repository:
+You can get the in-development Pylint source code from its bitbucket repository:
-http://www.logilab.org/src/pylint
+https://bitbucket.org/logilab/pylint
The same is true for Pylint dependencies (if you use Pylint code from the
repository, you should usually use code from the repository as well for astng
and common):
-http://www.logilab.org/src/logilab/astng
+https://bitbucket.org/logilab/astng
http://www.logilab.org/src/logilab/common
.. _mercurial: http://www.selenic.com/mercurial/