summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMichal Nowikowski <godfryd@gmail.com>2014-07-26 12:56:42 +0200
committerMichal Nowikowski <godfryd@gmail.com>2014-07-26 12:56:42 +0200
commitf5e97c90aa8de9178f4118f5e1c872a7b78dbdf1 (patch)
tree4ea542b1b97b904e1c290f00548347934cd6c366 /Makefile
parentb43aa5c9064351f70d495b85289a278fe5fca4ac (diff)
downloadpylint-f5e97c90aa8de9178f4118f5e1c872a7b78dbdf1.tar.gz
Added missing deps for building deb package.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 5002ea1..66e7822 100644
--- a/Makefile
+++ b/Makefile
@@ -38,7 +38,7 @@ docs: $(PIP)
. $(PYVE)/bin/activate; make all -C doc
deb: $(PKG_DEB)
-$(PKG_DEB): /usr/bin/debuild
+$(PKG_DEB): /usr/bin/debuild /usr/bin/dh_pysupport
debuild -b -us -uc
sdist: $(PKG_SDIST)
@@ -49,18 +49,21 @@ lint: $(PIP)
$(PIP) install .
$(PYVE)/bin/pylint lint.py || true # for now ignore errors
-clean: /usr/bin/debuild
+clean: /usr/bin/debuild /usr/bin/dh_pysupport
rm -rf $(PYVE)
rm -rf .tox
rm -rf dist
rm -rf build
make clean -C doc
debuild clean
- rm -rf $(PKG_DEB)
+ rm -rf $(PKG_DEB) ../pylint_*.changes ../pylint_*.build
/usr/bin/debuild:
sudo apt-get -y --force-yes install devscripts
+/usr/bin/dh_pysupport
+ sudo apt-get -y --force-yes install python-support
+
all: clean lint tests docs sdist deb
.PHONY: help tests docs deb sdist lint clean all