summaryrefslogtreecommitdiff
path: root/debian.sid/rules
diff options
context:
space:
mode:
authorSylvain Th?nault <sylvain.thenault@logilab.fr>2011-12-05 14:10:29 +0100
committerSylvain Th?nault <sylvain.thenault@logilab.fr>2011-12-05 14:10:29 +0100
commit17c5d6905a96f9e938673e2f030b0a8433c7f00a (patch)
tree75726248229735ab20dde1eb86497456dde96722 /debian.sid/rules
parent8dcf87cbc25e0d58c2ef669663f03d7dafd31228 (diff)
downloadpylint-17c5d6905a96f9e938673e2f030b0a8433c7f00a.tar.gz
[doc] update README.Python3 (closes: #82421)
Forget hardy distribution.
Diffstat (limited to 'debian.sid/rules')
-rwxr-xr-xdebian.sid/rules56
1 files changed, 56 insertions, 0 deletions
diff --git a/debian.sid/rules b/debian.sid/rules
new file mode 100755
index 0000000..6a0d59c
--- /dev/null
+++ b/debian.sid/rules
@@ -0,0 +1,56 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+#
+# adapted by Logilab for automatic generation by debianize
+# (part of the devtools project, http://www.logilab.org/projects/devtools)
+#
+# Copyright (c) 2003-2010 LOGILAB S.A. (Paris, FRANCE).
+# http://www.logilab.fr/ -- mailto:contact@logilab.fr
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+include /usr/share/python/python.mk
+
+PYLIB:=$(call py_libdir,$(shell pyversions -d))
+PACKAGE:=$(call py_pkgname,pylint,python)
+PYLIB3:=$(call py_libdir,python3.)
+PACKAGE3:="pylint3"
+
+%:
+ dh $@ --with python2,python3
+
+override_dh_install:
+ NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
+ --root=$(CURDIR)/debian/$(PACKAGE)/ \
+ ${py_setup_install_args}
+ NO_SETUPTOOLS=1 python3 setup.py -q install --no-compile \
+ --root=$(CURDIR)/debian/$(PACKAGE3)/ \
+ ${py_setup_install_args}
+ # rename executables
+ for executable in pylint pylint-gui symilar epylint pyreverse ; do \
+ new_exec="$$executable"3; \
+ mv $(CURDIR)/debian/$(PACKAGE3)/usr/bin/$$executable $(CURDIR)/debian/$(PACKAGE3)/usr/bin/$$new_exec; \
+ done
+
+ # remove test directory
+ rm -rf debian/*/usr/lib/python*/*-packages/pylint/test
+
+ # generate pylint man page automatically
+ #PYTHONPATH=$(CURDIR)/debian/$(PACKAGE)/$(PYLIB) python $(CURDIR)/bin/pylint --generate-man > $(CURDIR)/man/pylint.1
+
+ # rename and install man pages
+ dh_installman -ppylint man/*.1
+ cd man && for i in *.1; do cp -v $$i "$$(basename $$i .1)3.1"; done
+ dh_installman -ppylint3 man/*3.1
+
+override_dh_installdocs:
+ dh_installdocs README*
+ dh_installchangelogs -i ChangeLog
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ # PYTHON 2.X
+ # PYTHON 3.2
+endif