summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorClaudiu Popa <devnull@localhost>2014-09-30 23:54:37 -0700
committerClaudiu Popa <devnull@localhost>2014-09-30 23:54:37 -0700
commitecbf6b1b7da92d84be8436c3afdf2a66f837dfa3 (patch)
treef47223f0f7b4c4dd9367e43c08acaaf2356fb4f8 /setup.py
parent70fc528bc9b1bdf4f569e393244a6184c1c87cc2 (diff)
downloadpylint-ecbf6b1b7da92d84be8436c3afdf2a66f837dfa3.tar.gz
Use with statement to prevent resource warnings.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 28b7d3e..61fb114 100644
--- a/setup.py
+++ b/setup.py
@@ -62,7 +62,8 @@ STD_BLACKLIST = ('CVS', '.svn', '.hg', 'debian', 'dist', 'build')
IGNORED_EXTENSIONS = ('.pyc', '.pyo', '.elc', '~')
if exists('README'):
- long_description = open('README').read()
+ with open('README') as stream:
+ long_description = stream.read()
else:
long_description = ''