summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog8
-rw-r--r--__pkginfo__.py8
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
4 files changed, 19 insertions, 5 deletions
diff --git a/ChangeLog b/ChangeLog
index 0023182..ff5cd3e 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,14 @@
ChangeLog for PyLint
====================
+2010-10-27 -- 0.21.4
+
+ * fix #48066: pylint crashes when redirecting output containing non-ascii characters
+
+ * fix #19799: "pylint -blah" exit with status 2
+
+ * update documentation
+
2010-09-28 -- 0.21.3
* restored python 2.3 compatibility. Along with logilab-astng
0.21.3 and logilab-common 0.52, this will much probably be the
diff --git a/__pkginfo__.py b/__pkginfo__.py
index 23a4a88..5fc62fa 100644
--- a/__pkginfo__.py
+++ b/__pkginfo__.py
@@ -18,11 +18,11 @@
modname = distname = 'pylint'
-numversion = (0, 21, 3)
+numversion = (0, 21, 4)
version = '.'.join([str(num) for num in numversion])
-install_requires = ['logilab-common >= 0.50.1',
- 'logilab-astng >= 0.20.1']
+install_requires = ['logilab-common >= 0.52.1',
+ 'logilab-astng >= 0.20.4']
license = 'GPL'
description = "python code static checker"
@@ -58,7 +58,7 @@ long_desc = """\
.
Additionally, it is possible to write plugins to add your own checks."""
-pyversions = ["2.3", "2.4", "2.5", '2.6'] # maybe 2.2 as well
+pyversions = ["2.3", "2.4", "2.5", '2.6', "2.7"]
from os.path import join
scripts = [join('bin', filename)
diff --git a/debian/changelog b/debian/changelog
index 426f73e..c39a6e6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+pylint (0.21.4-1) unstable; urgency=low
+
+ * new upstream release
+
+ -- Emile Anclin <emile.anclin@logilab.fr> Thu, 27 Oct 2010 13:54:44 +0100
+
pylint (0.21.3-1) unstable; urgency=low
* new upstream release
diff --git a/debian/control b/debian/control
index 299a26a..7c63185 100644
--- a/debian/control
+++ b/debian/control
@@ -13,7 +13,7 @@ Vcs-Browser: http://svn.debian.org/viewsvn/python-apps/packages/pylint/trunk/
Package: pylint
Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}, python-logilab-common (>= 0.50.1), python-logilab-astng (>= 0.20.1)
+Depends: ${python:Depends}, ${misc:Depends}, python-logilab-common (>= 0.52.1), python-logilab-astng (>= 0.20.4)
Recommends: python-tk
XB-Python-Version: ${python:Versions}
Conflicts: python2.2-pylint, python2.3-pylint, python2.4-pylint, pylint-common, pylint-test