summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MANIFEST.in1
-rw-r--r--__pkginfo__.py1
-rw-r--r--debian.py3k/control4
-rwxr-xr-xdebian.py3k/rules20
4 files changed, 21 insertions, 5 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 2fcee65..f3aab91 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,6 +1,7 @@
include ChangeLog
include COPYING
include DEPENDS
+include README*
include bin/*
include examples/*
include elisp/*
diff --git a/__pkginfo__.py b/__pkginfo__.py
index 4b0edcb..b4442f5 100644
--- a/__pkginfo__.py
+++ b/__pkginfo__.py
@@ -24,6 +24,7 @@ version = '.'.join([str(num) for num in numversion])
install_requires = ['logilab-common >= 0.53.0', 'logilab-astng >= 0.21.0']
license = 'GPL'
+copyright = 'Logilab S.A.'
description = "python code static checker"
web = "http://www.logilab.org/project/%s" % distname
ftp = "ftp://ftp.logilab.org/pub/%s" % modname
diff --git a/debian.py3k/control b/debian.py3k/control
index 2ac71a2..82393f7 100644
--- a/debian.py3k/control
+++ b/debian.py3k/control
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Logilab S.A. <contact@logilab.fr>
Uploaders: Sylvain Thénault <sylvain.thenault@logilab.fr>, Alexandre Fayolle <afayolle@debian.org>,
Sandro Tosi <morph@debian.org>, Julien Jehannet <julien.jehannet@logilab.fr>
-Build-Depends: debhelper (>= 7.0.50~), python3-all
+Build-Depends: debhelper (>= 7.0.50~), python3-all, python3-logilab-common, python3-logilab-astng
Standards-Version: 3.9.1
Homepage: http://www.logilab.org/project/pylint
Vcs-Hg: http://hg.logilab.org/pylint
@@ -12,7 +12,7 @@ Vcs-Browser: http://hg.logilab.org/pylint
Package: pylint3
Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}, python3-logilab-common (>= 0.53), python3-logilab-astng (>= 0.22)
+Depends: ${python:Depends}, ${misc:Depends}, python3-logilab-common (>= 0.53), python3-logilab-astng (>= 0.21)
Recommends: python3-tk
XB-Python-Version: ${python:Versions}
Description: python code static checker and UML diagram generator
diff --git a/debian.py3k/rules b/debian.py3k/rules
index b5ea1a7..c608f85 100755
--- a/debian.py3k/rules
+++ b/debian.py3k/rules
@@ -5,30 +5,44 @@
# adapted by Logilab for automatic generation by debianize
# (part of the devtools project, http://www.logilab.org/projects/devtools)
#
-# Copyright (c) 2003-2008 LOGILAB S.A. (Paris, FRANCE).
+# Copyright (c) 2003-2010 LOGILAB S.A. (Paris, FRANCE).
# http://www.logilab.fr/ -- mailto:contact@logilab.fr
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
PACKAGE:=$(shell grep Package debian/control | cut -d ' ' -f2)
+PYDEF:=$(shell py3versions -dv)
include /usr/share/python3/python.mk
%:
dh --with python3 $@
+override_dh_auto_build:
+ # python module build
+ NO_SETUPTOOLS=1 python3 setup.py -q build --build-purelib $(CURDIR)/build/lib
+
override_dh_install:
NO_SETUPTOOLS=1 python3 setup.py -q install --no-compile \
--root=$(CURDIR)/debian/$(PACKAGE)/ \
${py_setup_install_args}
- find $(CURDIR)/debian/$(PACKAGE)/usr/lib/python*/*-packages/ ! -path "*/test/*py" -name "*py" -exec 2to3-3.1 -wn {} \;
+ find $(CURDIR)/debian/$(PACKAGE)/usr/lib/python*/*-packages/ ! -path "*/test/*py" -name "*py" -exec 2to3-$(PYDEF) -wn {} \;
+ # rename executables
for executable in pylint pylint-gui symilar epylint pyreverse ; do \
new_exec="$$executable"3; \
- mv -v $(CURDIR)/debian/$(PACKAGE)/usr/bin/$$executable $(CURDIR)/debian/$(PACKAGE)/usr/bin/$$new_exec; \
+ mv $(CURDIR)/debian/$(PACKAGE)/usr/bin/$$executable $(CURDIR)/debian/$(PACKAGE)/usr/bin/$$new_exec; \
done
# remove test directory
rm -rf debian/$(PACKAGE)/usr/lib/python*/*-packages/pylint/test
+ # generate pylint man page automatically (only when sources are py3k compatible)
+ PYTHONPATH=debian/$(PACKAGE)/usr/lib/python3/dist-packages python3 $(CURDIR)/bin/pylint --generate-man > $(CURDIR)/man/pylint.1
+ # rename and install man pages
+ for manpage in man/* ; do \
+ new_manpage="$(shell basename ${manpage} .1)"3.1; \
+ mv $$manpage $$new_manpage; \
+ done
+ dh_installman man/*
override_dh_installdocs:
dh_installdocs README*