summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 83fb5b8..cf6627d 100644
--- a/Makefile
+++ b/Makefile
@@ -28,10 +28,9 @@ tests: $(TOX)
$(TOX) $(toxparams)
docs: $(PIP)
- rm -f /tmp/pylint
- ln -s -f $(CURDIR) /tmp/pylint
$(PIP) install .
- PYTHONPATH=/tmp PATH=$(CURDIR)/pyve/bin:$(PATH) make all -C doc
+ $(PIP) install Sphinx
+ . pyve/bin/activate; make all -C doc
deb:
debuild -b -us -uc
@@ -43,7 +42,6 @@ lint: $(PIP)
clean:
rm -rf $(PYVE)
rm -rf .tox
- rm -rf /tmp/pylint1 /tmp/pylint2
make clean -C doc
debuild clean