summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.py10
1 files changed, 2 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index f208216..c5286f5 100644
--- a/setup.py
+++ b/setup.py
@@ -121,12 +121,6 @@ class MyInstallLib(install_lib.install_lib):
base = join(subpackage_of, modname)
else:
base = modname
- if sys.platform == 'win32':
- two_to_three = [sys.executable]
- exe_path = os.path.dirname(sys.executable)
- two_to_three.append(os.path.join(exe_path, 'Tools\\Scripts\\2to3.py'))
- else:
- two_to_three = ['2to3']
for directory in include_dirs:
dest = join(self.install_dir, base, directory)
if sys.version_info >= (3, 0):
@@ -139,9 +133,9 @@ class MyInstallLib(install_lib.install_lib):
if sys.version_info >= (3, 0):
# process manually python file in include_dirs (test data)
- from subprocess import call
+ from distutils.util import run_2to3
print('running 2to3 on', dest)
- call(two_to_three + ['-wn', dest])
+ run_2to3([dest])
def install(**kwargs):