summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog13
-rwxr-xr-xdebian/rules4
-rw-r--r--elisp/pylint.el24
-rw-r--r--elisp/startup2
4 files changed, 39 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 056a164..a24b13e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+pylint (0.14.0-2.1) unstable; urgency=low
+
+ * Non-maintainer upload.
+ * BF: flavor -> debian-emacs-flavor in startup
+ * NF: added pylint-options variable visible to users to tune up (closes:
+ #427244)
+ * BF: reenabled installation of pylint.el (closes: #448102)
+ * Recent upstream of pylint.el fixed few bugs which weren't closed
+ in the upload to Debian. Since this is first upload which enables
+ pylint.el, imho it is ok to close them here (closes: #415485, #431653)
+
+ -- Yaroslav Halchenko <debian@onerussian.com> Mon, 03 Mar 2008 22:22:07 -0500
+
pylint (0.14.0-2) unstable; urgency=low
* Acknowledge NMU by Kumar Appaiah <akumar@ee.iitm.ac.in> (Closes: #454401)
diff --git a/debian/rules b/debian/rules
index d85c762..06c3942 100755
--- a/debian/rules
+++ b/debian/rules
@@ -45,7 +45,7 @@ install: build
sed -i "s@^#! */usr/bin/env \+python\$$@#!/usr/bin/python@" debian/pylint/usr/bin/symilar; \
fi
chmod a+x debian/pylint/usr/bin/symilar
- #install -m 644 elisp/pylint.el debian/pylint/usr/share/emacs/site-lisp/pylint/
+ install -m 644 elisp/pylint.el debian/pylint/usr/share/emacs/site-lisp/pylint/
# install tests
#(cd test && find . -type f -not \( -path '*/CVS/*' -or -name '*.pyc' \) -exec install -D --mode=644 {} ../debian/pylint/usr/share/doc/pylint/test/{} \;)
@@ -62,7 +62,7 @@ binary-indep: build install
dh_installexamples -i
dh_installdocs -i README TODO changelog.gz debian/NEWS.Debian
dh_installman -i
-# dh_installemacsen
+ dh_installemacsen
dh_link -i
dh_compress -i -X.py -X.ini -X.xml -Xtest
dh_fixperms -i
diff --git a/elisp/pylint.el b/elisp/pylint.el
index 14960e9..5862a2e 100644
--- a/elisp/pylint.el
+++ b/elisp/pylint.el
@@ -1,5 +1,27 @@
(require 'compile)
+;;
+;; Modifications done by Yarosav O. Halchenko (2008):
+;; - enable user-visible variables
+;; distributed under the same copyright/license terms as
+;; pylint itself
+;;
+(require 'compile)
+
+;; user definable variables
+;; vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv
+
+(defgroup pylint nil
+ "Emacs support for the Pylint Python checker"
+ :group 'languages
+ :prefix "pylint-")
+
+(defcustom pylint-options "--output-format=parseable"
+ "*Command line options to be used with pylint call"
+ :type 'string
+ :group 'pylint)
+
+
;; adapted from pychecker for pylint
(defun pylint-python-hook ()
(defun pylint ()
@@ -8,7 +30,7 @@
(interactive)
(let* ((file (buffer-file-name (current-buffer)))
- (command (concat "pylint --output-format=parseable \"" file "\"")))
+ (command (concat "pylint " pylint-options " \"" file "\"")))
(save-some-buffers (not compilation-ask-about-save) nil) ; save files.
(compile-internal command "No more errors or warnings" "pylint")))
;; (local-set-key [f1] 'pylint)
diff --git a/elisp/startup b/elisp/startup
index ad9d071..fd40b42 100644
--- a/elisp/startup
+++ b/elisp/startup
@@ -12,6 +12,6 @@
;; installed in a subdirectory of the respective site-lisp directory.
;; We have to add this to the load-path:
(setq load-path (cons (concat "/usr/share/"
- (symbol-name flavor)
+ (symbol-name debian-emacs-flavor)
"/site-lisp/%PACKAGE%") load-path))
(load-library "pylint")