summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9820c47..5352833 100644
--- a/setup.py
+++ b/setup.py
@@ -132,6 +132,9 @@ class MyInstallLib(install_lib.install_lib):
exclude = set()
shutil.rmtree(dest, ignore_errors=True)
shutil.copytree(directory, dest)
+ # since python2.5's copytree doesn't support the ignore
+ # parameter, the following loop to remove the exclude set
+ # was added
for (dirpath, dirnames, filenames) in os.walk(dest):
for n in filenames:
if n in exclude: