summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRicardo Gemignani <ricardo.gemignani@gmail.com>2014-03-06 22:08:08 -0300
committerRicardo Gemignani <ricardo.gemignani@gmail.com>2014-03-06 22:08:08 -0300
commitb62a93ab0f8f3d442ee8e0155df7c8a9355816a7 (patch)
tree257d1a08a89ac5f36af204f7a700aaf553620f4b /setup.py
parent554f49e7d75d1cbbee7567c577744222295eadd4 (diff)
downloadpylint-b62a93ab0f8f3d442ee8e0155df7c8a9355816a7.tar.gz
code commented and import moved so it won't run when python>2.5
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9820c47..5352833 100644
--- a/setup.py
+++ b/setup.py
@@ -132,6 +132,9 @@ class MyInstallLib(install_lib.install_lib):
exclude = set()
shutil.rmtree(dest, ignore_errors=True)
shutil.copytree(directory, dest)
+ # since python2.5's copytree doesn't support the ignore
+ # parameter, the following loop to remove the exclude set
+ # was added
for (dirpath, dirnames, filenames) in os.walk(dest):
for n in filenames:
if n in exclude: