summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2018-03-21 14:49:42 +0100
committerAlex Gaynor <alex.gaynor@gmail.com>2018-03-21 09:49:42 -0400
commit1ae7cb68cd285fe822c84d8e3198aff9716cf4e8 (patch)
tree8b280f24b25c1f1d2b9e0478655d3fddbaf1468e /setup.py
parent993c4e4afc4274019bdb835b64191afeed6c13b7 (diff)
downloadpyopenssl-1ae7cb68cd285fe822c84d8e3198aff9716cf4e8.tar.gz
Raise minimum cryptography version to 2.2.1, drop python 2.6 (#742)
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 2 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 85252e9..5e80f0c 100755
--- a/setup.py
+++ b/setup.py
@@ -77,7 +77,6 @@ if __name__ == "__main__":
'Operating System :: POSIX',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.4',
@@ -95,16 +94,14 @@ if __name__ == "__main__":
package_dir={"": "src"},
install_requires=[
# Fix cryptographyMinimum in tox.ini when changing this!
- "cryptography>=2.1.4",
+ "cryptography>=2.2.1",
"six>=1.5.2"
],
extras_require={
"test": [
"flaky",
"pretend",
- # pytest 3.3 doesn't support Python 2.6 anymore.
- # Remove this pin once we drop Python 2.6 too.
- "pytest>=3.0.1,<3.3.0",
+ "pytest>=3.0.1",
],
"docs": [
"sphinx",