summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 2 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 85252e9..5e80f0c 100755
--- a/setup.py
+++ b/setup.py
@@ -77,7 +77,6 @@ if __name__ == "__main__":
'Operating System :: POSIX',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.4',
@@ -95,16 +94,14 @@ if __name__ == "__main__":
package_dir={"": "src"},
install_requires=[
# Fix cryptographyMinimum in tox.ini when changing this!
- "cryptography>=2.1.4",
+ "cryptography>=2.2.1",
"six>=1.5.2"
],
extras_require={
"test": [
"flaky",
"pretend",
- # pytest 3.3 doesn't support Python 2.6 anymore.
- # Remove this pin once we drop Python 2.6 too.
- "pytest>=3.0.1,<3.3.0",
+ "pytest>=3.0.1",
],
"docs": [
"sphinx",