summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFredrik Thulin <fredrik@thulin.net>2023-02-01 09:36:41 +0100
committerIvan Kanakarakis <ivan.kanak@gmail.com>2023-02-14 18:20:44 +0200
commit4d77c554f6c2e9d09f5ba1467bd88c781937ffab (patch)
tree6552b9c198582f14eb81721daa26523f84f9bc07
parent13ddd1fad436df4c23cf93b340c07a9aeaf2ad47 (diff)
downloadpysaml2-4d77c554f6c2e9d09f5ba1467bd88c781937ffab.tar.gz
enable mypy config
Run with "poetry run mypy src".
-rw-r--r--pyproject.toml25
1 files changed, 13 insertions, 12 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e7d66b9a..6f9ec662 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -225,15 +225,16 @@ src_paths = [
'test',
]
-# XXX TODO
-#[tool.mypy]
-#pretty = true
-#check_untyped_defs = true
-#ignore_errors = false
-#ignore_missing_imports = true
-#show_error_codes = true
-#strict_optional = true
-#warn_unused_ignores = true
-#warn_redundant_casts = true
-#warn_unused_configs = true
-#warn_unreachable = true
+[tool.mypy]
+pretty = true
+check_untyped_defs = false
+ignore_errors = false
+ignore_missing_imports = true
+show_error_codes = true
+strict_optional = true
+warn_unused_ignores = true
+warn_redundant_casts = true
+warn_unused_configs = true
+warn_unreachable = true
+install_types = true
+non_interactive = true