summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Liechti <cliechti@gmx.net>2020-09-21 02:38:31 +0200
committerChris Liechti <cliechti@gmx.net>2020-09-21 02:38:31 +0200
commit6ae64c15c5722683f52e33930577d54f83446be9 (patch)
treec9c3dd7cdf1f1dfd0f201f6a25124540ee5db07e
parent4e661141e8bb4becc1ad4470cc42fbb081dfbe39 (diff)
downloadpyserial-git-6ae64c15c5722683f52e33930577d54f83446be9.tar.gz
setup: change entry points, update classifiers
related to #466 #360
-rw-r--r--.gitignore4
-rw-r--r--CHANGES.rst7
-rw-r--r--serial/__main__.py3
-rw-r--r--setup.py11
4 files changed, 20 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
index fb44ebb..fdbfde0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -8,4 +8,6 @@ dist
/MANIFEST
-.idea \ No newline at end of file
+.idea
+venv
+xxx*
diff --git a/CHANGES.rst b/CHANGES.rst
index 632014e..4515692 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -750,10 +750,15 @@ Improvements:
- [#372] threaded: "write" returns byte count
- [#400] Add bytesize and stopbits argument parser to tcp_serial_redirect
- [#408] loop: add out_waiting
+- [#495] list_ports_linux: Correct "interface" property on Linux hosts
- [#500] Remove Python 3.2 and 3.3 from test
-- doc updates [#261, #296, #320, #333, #285, #356, #358, #342, #397, #389, #510]
+- [#261, #285, #296, #320, #333, #342, #356, #358, #389, #397, #510] doc updates
- miniterm: add :kbd:`CTRL+T Q` as alternative to exit
- miniterm: suspend function key changed to :kbd:`CTRL-T Z`
+- add command line tool entries ``pyserial-miniterm`` (replaces ``miniterm.py``)
+ and ``pyserial-ports`` (runs ``serial.tools.list_ports``).
+- ``python -m serial`` opens miniterm (use w/o args and it will print port
+ list too) [experimental]
Bugfixes:
diff --git a/serial/__main__.py b/serial/__main__.py
new file mode 100644
index 0000000..bd0a2e6
--- /dev/null
+++ b/serial/__main__.py
@@ -0,0 +1,3 @@
+from .tools import miniterm
+
+miniterm.main()
diff --git a/setup.py b/setup.py
index 9b5b73b..2aee8b1 100644
--- a/setup.py
+++ b/setup.py
@@ -85,18 +85,23 @@ Latest:
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Topic :: Communications',
'Topic :: Software Development :: Libraries',
'Topic :: Software Development :: Libraries :: Python Modules',
'Topic :: Terminals :: Serial',
],
platforms='any',
- scripts=['serial/tools/miniterm.py'],
+ entry_points = {
+ 'console_scripts': [
+ 'pyserial-miniterm=serial.tools.miniterm:main',
+ 'pyserial-ports=serial.tools.list_ports:main'
+ ],
+ },
extras_require = {
'cp2110': ['hidapi'],
},