summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 8 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 9b5b73b..2aee8b1 100644
--- a/setup.py
+++ b/setup.py
@@ -85,18 +85,23 @@ Latest:
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Topic :: Communications',
'Topic :: Software Development :: Libraries',
'Topic :: Software Development :: Libraries :: Python Modules',
'Topic :: Terminals :: Serial',
],
platforms='any',
- scripts=['serial/tools/miniterm.py'],
+ entry_points = {
+ 'console_scripts': [
+ 'pyserial-miniterm=serial.tools.miniterm:main',
+ 'pyserial-ports=serial.tools.list_ports:main'
+ ],
+ },
extras_require = {
'cp2110': ['hidapi'],
},