summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris Liechti <cliechti@gmx.net>2020-09-21 02:38:31 +0200
committerChris Liechti <cliechti@gmx.net>2020-09-21 02:38:31 +0200
commit6ae64c15c5722683f52e33930577d54f83446be9 (patch)
treec9c3dd7cdf1f1dfd0f201f6a25124540ee5db07e /setup.py
parent4e661141e8bb4becc1ad4470cc42fbb081dfbe39 (diff)
downloadpyserial-git-6ae64c15c5722683f52e33930577d54f83446be9.tar.gz
setup: change entry points, update classifiers
related to #466 #360
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 8 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 9b5b73b..2aee8b1 100644
--- a/setup.py
+++ b/setup.py
@@ -85,18 +85,23 @@ Latest:
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Topic :: Communications',
'Topic :: Software Development :: Libraries',
'Topic :: Software Development :: Libraries :: Python Modules',
'Topic :: Terminals :: Serial',
],
platforms='any',
- scripts=['serial/tools/miniterm.py'],
+ entry_points = {
+ 'console_scripts': [
+ 'pyserial-miniterm=serial.tools.miniterm:main',
+ 'pyserial-ports=serial.tools.list_ports:main'
+ ],
+ },
extras_require = {
'cp2110': ['hidapi'],
},