summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 88893df7..a6a10814 100644
--- a/setup.py
+++ b/setup.py
@@ -40,6 +40,10 @@ def howto_install_setuptools():
Then you could make eggs from this package.
""")
+if sys.version_info[:2] < (2, 4):
+ print("ERROR: this package requires Python 2.4 or later!")
+ sys.exit(1)
+
try:
from setuptools import setup
params = {