summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorelie <elie>2013-09-21 10:10:34 +0000
committerelie <elie>2013-09-21 10:10:34 +0000
commit9ed7f54b6500659183a123ed170381979970c419 (patch)
tree4a98e467dcf16ce252fb6b0451937b5696c0bce4 /setup.py
parenta467f2632d90df9377562956595c4323fa689125 (diff)
downloadpysnmp-git-9ed7f54b6500659183a123ed170381979970c419.tar.gz
Python 2.4+ installation requirement added
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 88893df7..a6a10814 100644
--- a/setup.py
+++ b/setup.py
@@ -40,6 +40,10 @@ def howto_install_setuptools():
Then you could make eggs from this package.
""")
+if sys.version_info[:2] < (2, 4):
+ print("ERROR: this package requires Python 2.4 or later!")
+ sys.exit(1)
+
try:
from setuptools import setup
params = {