summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris Wanstrath <chris@ozmm.org>2010-02-15 11:33:50 -0800
committerChris Wanstrath <chris@ozmm.org>2010-02-15 11:33:50 -0800
commit4ac53c96805f2334d1e8378b9cc168e137311f05 (patch)
treef6d8fdbb360d25e479566e0d8c3f8988635a160b /setup.py
parentcfa229ff3e204d4f00e982de68d1fa39a129a438 (diff)
downloadpystache-4ac53c96805f2334d1e8378b9cc168e137311f05.tar.gz
`python setup.py publish`
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 53ae4c9..a763e2c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,20 @@
#!/usr/bin/env python
+import os
+import sys
+
from distutils.core import setup
+def publish():
+ """Publish to Pypi"""
+ os.system("python setup.py sdist upload")
+
+if sys.argv[-1] == "publish":
+ publish()
+ sys.exit()
+
+
+
setup(name='pystache',
version='0.2.0',
description='Mustache for Python',
@@ -11,3 +24,4 @@ setup(name='pystache',
packages=['pystache'],
license='MIT'
)
+