summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 53ae4c9..a763e2c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,20 @@
#!/usr/bin/env python
+import os
+import sys
+
from distutils.core import setup
+def publish():
+ """Publish to Pypi"""
+ os.system("python setup.py sdist upload")
+
+if sys.argv[-1] == "publish":
+ publish()
+ sys.exit()
+
+
+
setup(name='pystache',
version='0.2.0',
description='Mustache for Python',
@@ -11,3 +24,4 @@ setup(name='pystache',
packages=['pystache'],
license='MIT'
)
+