summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris Jerdonek <chris.jerdonek@gmail.com>2011-12-10 18:23:12 -0800
committerChris Jerdonek <chris.jerdonek@gmail.com>2011-12-10 18:23:12 -0800
commitf9d233b4c9e7dd90383f1bf60512a6abd81d3aaf (patch)
tree574b174a9446059d112c0c5f2ddbf5cd617f76d0 /setup.py
parentf2c116c2b9e22904a4eb916f922a18847fe58d36 (diff)
parent43d504b5dbdb043cdfe9a87ffb4b3b239c130ab8 (diff)
downloadpystache-f9d233b4c9e7dd90383f1bf60512a6abd81d3aaf.tar.gz
Merge pull request #29 (5) "setup.py cleanup"
From: https://github.com/kennethreitz/pystache/commit/43d504b5dbdb043cdfe9a87ffb4b3b239c130ab8 Into: issue_29 This commit includes a few tweaks to setup.py. The indentation of the arguments to setup() was left alone.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 8 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index ad9981f..8433c34 100644
--- a/setup.py
+++ b/setup.py
@@ -1,18 +1,22 @@
#!/usr/bin/env python
+# coding: utf-8
import os
import sys
+
try:
from setuptools import setup
except ImportError:
from distutils.core import setup
+
def publish():
"""Publish to Pypi"""
- os.system("python setup.py sdist upload")
+ os.system('python setup.py sdist upload')
+
-if sys.argv[-1] == "publish":
+if sys.argv[-1] == 'publish':
publish()
sys.exit()
@@ -25,12 +29,12 @@ setup(name='pystache',
url='http://github.com/defunkt/pystache',
packages=['pystache'],
license='MIT',
- classifiers = (
+ classifiers = (
"Development Status :: 4 - Beta",
"License :: OSI Approved :: MIT License",
"Programming Language :: Python",
"Programming Language :: Python :: 2.5",
"Programming Language :: Python :: 2.6",
)
- )
+)