summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Socol <me@jamessocol.com>2022-11-06 09:11:24 -0500
committerJames Socol <me@jamessocol.com>2022-11-06 09:12:23 -0500
commit4ed8d13a82b2e7be85f32a9e4d797534e6a3ba69 (patch)
treeb4d46b208529029d67812f78e1cfc176e818d1da
parentaed950421ffeff606d8867311f59c2a32a12b3ef (diff)
downloadpystatsd-4ed8d13a82b2e7be85f32a9e4d797534e6a3ba69.tar.gz
Release v4.0.1
The trove classifiers for Python versions was bothering me too much.
-rw-r--r--CHANGELOG.md8
-rw-r--r--docs/conf.py2
-rw-r--r--pyproject.toml9
-rw-r--r--statsd/__init__.py2
4 files changed, 14 insertions, 7 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index bb86c10..d476d11 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,13 @@
# Statsd Changelog
+## UNRELEASED
+
+## v4.0.1
+
+### Fixed
+
+- Updated PyPI trove classifiers for current Python versions.
+
## v4.0
### Added
diff --git a/docs/conf.py b/docs/conf.py
index 71cfeee..55aef11 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -50,7 +50,7 @@ copyright = u'2015, James Socol'
# The short X.Y version.
version = '4.0'
# The full version, including alpha/beta/rc tags.
-release = '4.0.0'
+release = '4.0.1'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/pyproject.toml b/pyproject.toml
index faed4aa..b931110 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -4,7 +4,7 @@ build-backend = "setuptools.build_meta"
[project]
name = "statsd"
-version = "4.0.0"
+version = "4.0.1"
authors = [{name = "James Socol", email = "me@jamessocol.com"}]
license = {text = "MIT"}
description = "A simple statsd client."
@@ -16,13 +16,12 @@ classifiers = [
"License :: OSI Approved :: MIT License",
"Operating System :: OS Independent",
"Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.5",
- "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
"Topic :: Software Development :: Libraries :: Python Modules",
]
urls = {Homepage = "https://github.com/jsocol/pystatsd"}
diff --git a/statsd/__init__.py b/statsd/__init__.py
index 4834ecd..839a767 100644
--- a/statsd/__init__.py
+++ b/statsd/__init__.py
@@ -3,6 +3,6 @@ from .client import TCPStatsClient
from .client import UnixSocketStatsClient
-VERSION = (4, 0, 0)
+VERSION = (4, 0, 1)
__version__ = '.'.join(map(str, VERSION))
__all__ = ['StatsClient', 'TCPStatsClient', 'UnixSocketStatsClient']