summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Socol <me@jamessocol.com>2022-11-05 19:49:26 -0400
committerGitHub <noreply@github.com>2022-11-05 19:49:26 -0400
commitaed950421ffeff606d8867311f59c2a32a12b3ef (patch)
tree02e27fdd5ad3369651cc07f2a2f9aaf3f4578634
parenteda702fb46649d932b6ef0b223a238b1bad64fe5 (diff)
parentacc60849b94eaf316d3e0cca943cf5696c5f3d44 (diff)
downloadpystatsd-aed950421ffeff606d8867311f59c2a32a12b3ef.tar.gz
Merge pull request #173 from jsocol/release/v4v4.0.0
Bump version to v4.0.0
-rw-r--r--CHANGELOG.md2
-rw-r--r--docs/conf.py4
-rw-r--r--pyproject.toml4
-rw-r--r--statsd/__init__.py2
4 files changed, 6 insertions, 6 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 71d3666..bb86c10 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,6 @@
# Statsd Changelog
-## Unreleased
+## v4.0
### Added
diff --git a/docs/conf.py b/docs/conf.py
index 341fd48..71cfeee 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -48,9 +48,9 @@ copyright = u'2015, James Socol'
# built documents.
#
# The short X.Y version.
-version = '3.3'
+version = '4.0'
# The full version, including alpha/beta/rc tags.
-release = '3.3.0'
+release = '4.0.0'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/pyproject.toml b/pyproject.toml
index ed8df29..faed4aa 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -4,8 +4,8 @@ build-backend = "setuptools.build_meta"
[project]
name = "statsd"
-version = "3.3.0"
-authors = [{name = "James Socol", email = "james@mozilla.com"}]
+version = "4.0.0"
+authors = [{name = "James Socol", email = "me@jamessocol.com"}]
license = {text = "MIT"}
description = "A simple statsd client."
readme = "README.rst"
diff --git a/statsd/__init__.py b/statsd/__init__.py
index d12ade1..4834ecd 100644
--- a/statsd/__init__.py
+++ b/statsd/__init__.py
@@ -3,6 +3,6 @@ from .client import TCPStatsClient
from .client import UnixSocketStatsClient
-VERSION = (3, 2, 1)
+VERSION = (4, 0, 0)
__version__ = '.'.join(map(str, VERSION))
__all__ = ['StatsClient', 'TCPStatsClient', 'UnixSocketStatsClient']