summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanne Moa <hanne.moa@uninett.no>2019-02-21 09:34:23 +0100
committerHanne Moa <hanne.moa@uninett.no>2019-02-21 09:35:36 +0100
commit75654f5d9b16fb06899b487db46eb6680b3bc14b (patch)
tree4af4b975f8b353d22935bf89a875949be5fd98d2
parentbad41222379102e3f18f6f2f7be3ee608de6fbff (diff)
downloadpython-memcached-75654f5d9b16fb06899b487db46eb6680b3bc14b.tar.gz
Add testing for Python 3.7
-rw-r--r--.travis.yml1
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
3 files changed, 3 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 47cb22e..47a2698 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,6 +4,7 @@ python:
- 3.4
- 3.5
- 3.6
+ - 3.7
- pypy
services:
- memcached
diff --git a/setup.py b/setup.py
index 93cbe4d..d4e7645 100644
--- a/setup.py
+++ b/setup.py
@@ -33,5 +33,6 @@ setup(
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
],
)
diff --git a/tox.ini b/tox.ini
index 7d4fc52..f2d67ef 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
minversion = 1.6
-envlist = py27,py34,py35,p36,pypy,pep8
+envlist = py27,py{34,35,36,37},pypy,pep8
skipsdist = True
[testenv]