summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Reifschneider <sean@realgo.com>2023-04-15 17:39:51 -0600
committerSean Reifschneider <sean@realgo.com>2023-04-15 17:39:51 -0600
commit844385cdd978b2dd03f0b62436b947fb88456b51 (patch)
tree10ad16a95de95afdae9378b13bcd0fadc1dcaf5d
parentf416758657770e7fdb0d7a3ac03db598048db3c4 (diff)
downloadpython-memcached-844385cdd978b2dd03f0b62436b947fb88456b51.tar.gz
Removing Py 2.7, adding 3.8-3.11
-rw-r--r--.travis.yml7
-rw-r--r--setup.py8
-rw-r--r--tox.ini2
3 files changed, 9 insertions, 8 deletions
diff --git a/.travis.yml b/.travis.yml
index 47a2698..aa98469 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,10 +1,11 @@
language: python
python:
- - 2.7
- - 3.4
- - 3.5
- 3.6
- 3.7
+ - 3.8
+ - 3.9
+ - 3.10
+ - 3.11
- pypy
services:
- memcached
diff --git a/setup.py b/setup.py
index d0cc6df..12da42a 100644
--- a/setup.py
+++ b/setup.py
@@ -28,12 +28,12 @@ setup(
"Topic :: Internet",
"Topic :: Software Development :: Libraries :: Python Modules",
"Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.4",
- "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
],
)
diff --git a/tox.ini b/tox.ini
index f2d67ef..1e2a8f0 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
minversion = 1.6
-envlist = py27,py{34,35,36,37},pypy,pep8
+envlist = py{36,37,38,39,310,311},pypy,pep8
skipsdist = True
[testenv]