summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Reifschneider <jafo00@gmail.com>2023-04-15 17:35:12 -0600
committerGitHub <noreply@github.com>2023-04-15 17:35:12 -0600
commitf416758657770e7fdb0d7a3ac03db598048db3c4 (patch)
tree11dc5311f6d4592015f375ebda3c6f60b15a83fd
parent8ded8c327618765eb5501dbb554ffb82e952271d (diff)
parent75654f5d9b16fb06899b487db46eb6680b3bc14b (diff)
downloadpython-memcached-f416758657770e7fdb0d7a3ac03db598048db3c4.tar.gz
Merge pull request #160 from hmpf/py37
Add testing for Python 3.7
-rw-r--r--.travis.yml1
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
3 files changed, 3 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 47cb22e..47a2698 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,6 +4,7 @@ python:
- 3.4
- 3.5
- 3.6
+ - 3.7
- pypy
services:
- memcached
diff --git a/setup.py b/setup.py
index 797cd75..d0cc6df 100644
--- a/setup.py
+++ b/setup.py
@@ -34,5 +34,6 @@ setup(
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
],
)
diff --git a/tox.ini b/tox.ini
index 7d4fc52..f2d67ef 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
minversion = 1.6
-envlist = py27,py34,py35,p36,pypy,pep8
+envlist = py27,py{34,35,36,37},pypy,pep8
skipsdist = True
[testenv]