summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTax <paultax@gmail.com>2012-10-03 15:30:27 +0200
committerTax <paultax@gmail.com>2012-10-03 15:30:27 +0200
commit4e9a55a5b48d6cde8344b94fa0cd6ffbc1b24747 (patch)
treeb29b12240f5fa237ac40577ceaa089b16e95ad2c
parent1ff9b0bd70626d0131eed530b723ac269dd99f5d (diff)
downloadpython-requests-aws-4e9a55a5b48d6cde8344b94fa0cd6ffbc1b24747.tar.gz
creating python package
-rw-r--r--MANIFEST5
-rw-r--r--MANIFEST.in1
-rw-r--r--setup.py14
3 files changed, 20 insertions, 0 deletions
diff --git a/MANIFEST b/MANIFEST
new file mode 100644
index 0000000..805632f
--- /dev/null
+++ b/MANIFEST
@@ -0,0 +1,5 @@
+README.md
+awsauth.py
+example.py
+setup.py
+test.py
diff --git a/MANIFEST.in b/MANIFEST.in
new file mode 100644
index 0000000..98e7d2c
--- /dev/null
+++ b/MANIFEST.in
@@ -0,0 +1 @@
+include README.md *.py \ No newline at end of file
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..cfddb38
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,14 @@
+# -*- coding: utf-8 -*-
+from distutils.core import setup
+
+setup(
+ name='requests-aws',
+ version='0.1.0',
+ author='Paul Tax',
+ author_email='paultax@gmail.com',
+ #packages=['requests-aws'],
+ url='https://github.com/tax/python-requests-aws',
+ license='BSD licence, see LICENCE.txt',
+ description='AWS authentication for Amazon S3 for the python requests module',
+ long_description=open('README.md').read(),
+) \ No newline at end of file