summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul <paultax@gmail.com>2012-11-16 23:13:31 +0100
committerPaul <paultax@gmail.com>2012-11-16 23:13:31 +0100
commited731aa1ba663cf66bbbc30b8bc86e9d07c11108 (patch)
treed3232b031939020d19a04a880652c60af7323557
parent4e9a55a5b48d6cde8344b94fa0cd6ffbc1b24747 (diff)
downloadpython-requests-aws-ed731aa1ba663cf66bbbc30b8bc86e9d07c11108.tar.gz
PIP installation
Bam installation via PIP
-rw-r--r--README.md11
-rw-r--r--setup.py23
2 files changed, 28 insertions, 6 deletions
diff --git a/README.md b/README.md
index b93e730..4a9ad5f 100644
--- a/README.md
+++ b/README.md
@@ -12,7 +12,7 @@ AWS authentication for Amazon S3 for the wonderful [pyhon requests library](http
import requests
from awsauth import S3Auth
-ACCESS_KEY = 'ACCESSKEYXXXXXXXXXXXX'
+ACCESS_KEY = 'ACCESSKEYXXXXXXXXXXXX'
SECRET_KEY = 'AWSSECRETKEYXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX'
s = 'Sam is sweet'
@@ -27,4 +27,11 @@ if r.content == 'Sam is sweet':
# Removing a file
r = requests.delete('http://mybucket.s3.amazonaws.com/file.txt', auth=S3Auth(ACCESS_KEY, SECRET_KEY))
-``` \ No newline at end of file
+```
+
+## Installation
+Installing requests-aws is simple with pip:
+
+```
+ $ pip install requests-aws
+```
diff --git a/setup.py b/setup.py
index cfddb38..20c107e 100644
--- a/setup.py
+++ b/setup.py
@@ -1,14 +1,29 @@
# -*- coding: utf-8 -*-
-from distutils.core import setup
+import os
+import sys
+
+try:
+ from setuptools import setup
+ # hush pyflakes
+ setup
+except ImportError:
+ from distutils.core import setup
+
+if sys.argv[-1] == 'publish':
+ os.system('python setup.py sdist upload')
+ sys.exit()
setup(
name='requests-aws',
- version='0.1.0',
+ version='0.1.1',
author='Paul Tax',
author_email='paultax@gmail.com',
- #packages=['requests-aws'],
+ include_package_data=True,
+ install_requires = ['requests>=0.14.0'],
+ py_modules=['requests-aws'],
url='https://github.com/tax/python-requests-aws',
license='BSD licence, see LICENCE.txt',
description='AWS authentication for Amazon S3 for the python requests module',
long_description=open('README.md').read(),
-) \ No newline at end of file
+)
+