summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVal Neekman (AvidCoder) <un33kvu@gmail.com>2022-11-18 13:45:02 -0500
committerVal Neekman (AvidCoder) <un33kvu@gmail.com>2022-11-18 13:45:02 -0500
commita2aaded6a0589292b1c56dc2f3d08778dd97914f (patch)
tree2fbc6d9e2f730650ee250035f76e685693175af9
parent5ce9210079597a39d57bf9cbe406a3db23cac414 (diff)
parenta229e483b6f82f36600e73e7a2fb62dc2f5e7ed3 (diff)
downloadpython-slugify-a2aaded6a0589292b1c56dc2f3d08778dd97914f.tar.gz
upgrade py to 3.11
-rw-r--r--.github/workflows/ci.yml6
-rw-r--r--.github/workflows/dev.yml6
-rw-r--r--.github/workflows/main.yml6
-rw-r--r--CHANGELOG.md4
-rw-r--r--README.md1
-rw-r--r--setup.cfg2
-rwxr-xr-xsetup.py4
-rw-r--r--slugify/__init__.py8
-rw-r--r--slugify/__version__.py2
9 files changed, 25 insertions, 14 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index 4148354..da3899e 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -14,12 +14,12 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python: [3.6, 3.7, 3.8, 3.9, "3.10", pypy3]
+ python: [3.7, 3.8, 3.9, 3.10, 3.11, pypy3.8]
steps:
- - uses: actions/checkout@v2
+ - uses: actions/checkout@v3
- name: setup python
- uses: actions/setup-python@v2
+ uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python }}
- name: Install dependencies
diff --git a/.github/workflows/dev.yml b/.github/workflows/dev.yml
index d0cb401..615e82a 100644
--- a/.github/workflows/dev.yml
+++ b/.github/workflows/dev.yml
@@ -14,12 +14,12 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python: [3.6, 3.7, 3.8, 3.9, "3.10", pypy3]
+ python: [3.7, 3.8, 3.9, 3.10, 3.11, pypy3.8]
steps:
- - uses: actions/checkout@v2
+ - uses: actions/checkout@v3
- name: setup python
- uses: actions/setup-python@v2
+ uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python }}
- name: Install dependencies
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index f1e75b7..68d30fa 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -13,12 +13,12 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python: [3.6, 3.7, 3.8, 3.9, "3.10", pypy3]
+ python: [3.7, 3.8, 3.9, 3.10, 3.11, pypy3.8]
steps:
- - uses: actions/checkout@v2
+ - uses: actions/checkout@v3
- name: setup python
- uses: actions/setup-python@v2
+ uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python }}
- name: Install dependencies
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 2ba0bb3..b95783a 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,3 +1,7 @@
+## 7.0.0
+
+- Drop python 3.6, add python 3.11
+
## 6.1.2
- Reintroduce the cli options
diff --git a/README.md b/README.md
index f93afee..2514fc5 100644
--- a/README.md
+++ b/README.md
@@ -20,6 +20,7 @@ However, there is an alternative decoding package called [Unidecode](https://git
- Python `2.7` <-> python-slugify `< 5.0.0`
- Python `3.6+` <-> python-slugify `>= 5.0.0`
+- Python `3.7+` <-> python-slugify `>= 7.0.0`
# How to install
diff --git a/setup.cfg b/setup.cfg
deleted file mode 100644
index 3c6e79c..0000000
--- a/setup.cfg
+++ /dev/null
@@ -1,2 +0,0 @@
-[bdist_wheel]
-universal=1
diff --git a/setup.py b/setup.py
index c3c4b3b..65c72f4 100755
--- a/setup.py
+++ b/setup.py
@@ -9,7 +9,7 @@ from setuptools import setup
package = 'slugify'
-python_requires = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*, !=3.5.*"
+python_requires = ">=3.7"
here = os.path.abspath(os.path.dirname(__file__))
install_requires = ['text-unidecode>=1.3']
@@ -75,11 +75,11 @@ setup(
'License :: OSI Approved :: MIT License',
'Programming Language :: Python',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
],
entry_points={'console_scripts': ['slugify=slugify.__main__:main']},
)
diff --git a/slugify/__init__.py b/slugify/__init__.py
index ac21492..6d3279f 100644
--- a/slugify/__init__.py
+++ b/slugify/__init__.py
@@ -1,2 +1,10 @@
from .special import *
from .slugify import *
+from .__version__ import __title__
+from .__version__ import __author__
+from .__version__ import __author_email__
+from .__version__ import __description__
+from .__version__ import __url__
+from .__version__ import __license__
+from .__version__ import __copyright__
+from .__version__ import __version__
diff --git a/slugify/__version__.py b/slugify/__version__.py
index 55abc97..184339a 100644
--- a/slugify/__version__.py
+++ b/slugify/__version__.py
@@ -5,4 +5,4 @@ __description__ = 'A Python slugify application that also handles Unicode'
__url__ = 'https://github.com/un33k/python-slugify'
__license__ = 'MIT'
__copyright__ = 'Copyright 2022 Val Neekman @ Neekware Inc.'
-__version__ = '6.1.2'
+__version__ = '7.0.0'