summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-10-28 09:54:11 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-10-28 09:54:11 -0400
commit644e11f398427054b17a5f71f5cb89140c2a90bc (patch)
tree3c12da11659f75205240848d822341e3726ab496
parent94ee7ed0f916d6ccf43f2709086dcb3173a6a01b (diff)
downloadpython-systemd-644e11f398427054b17a5f71f5cb89140c2a90bc.tar.gz
build-sys: make sure we use modules from the build dir
When running form the top source directory, sometimes modules from systemd/ and not build/*/systemd/ were loaded.
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 05a0504..62d36fc 100644
--- a/Makefile
+++ b/Makefile
@@ -36,7 +36,7 @@ sphinx-%: build
@echo Output has been generated in build/docs
check: build
- $(PYTHON) -m py.test $(builddir) docs $(TESTFLAGS)
+ (cd $(builddir) && $(PYTHON) -m py.test . ../../docs $(TESTFLAGS))
TAGS: $(shell git ls-files systemd/*.[ch])
$(ETAGS) $+