summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-06-16 17:37:53 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-06-16 17:37:53 +0200
commita17f3c0ec568b657fe8cac0f11a5f33fc8892692 (patch)
treee8b4fd816d661dd4810a2a8e613513498f19a8c6
parent36c57e52be1926693bae071bcc79fbde5165e7d2 (diff)
downloadpython-systemd-a17f3c0ec568b657fe8cac0f11a5f33fc8892692.tar.gz
make: use -std=c99
I see no good reason to support old standards, when systemd itself requires c99. Let's test with c99 in the CI. Closes #62.
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 26f75b8..2d2eedf 100644
--- a/Makefile
+++ b/Makefile
@@ -7,6 +7,8 @@ INCLUDE_FLAGS := $(shell pkg-config --cflags libsystemd)
VERSION := $(shell $(PYTHON) setup.py --version)
TESTFLAGS = -v
+CFLAGS = -std=c99
+
define buildscript
import sys,sysconfig
print("build/lib.{}-{}.{}".format(sysconfig.get_platform(), *sys.version_info[:2]))
@@ -31,7 +33,7 @@ update-constants: update-constants.py $(INCLUDE_DIR)/systemd/sd-messages.h
mv docs/id128.rst{.tmp,}
build:
- $(PYTHON) setup.py build_ext $(INCLUDE_FLAGS)
+ CFLAGS=$(CFLAGS) $(PYTHON) setup.py build_ext $(INCLUDE_FLAGS)
$(PYTHON) setup.py build
install: